Steuerungsdefinition – Übersicht

Die Steuerungsdefinition hat zwei Hauptfunktionen:

  • Sie liefert dem Postprozessor die Daten, die er zur korrekten Verarbeitung der Werkzeugwegdaten für die gewählte Maschinendefinition benötigt. Hierdurch kann der Postprozessor eine NC-Datei erzeugen, die den Anforderungen der Steuerung entspricht.

  • Sie liefert Mastercam Daten zu Funktionsumfang und Anforderungen von Steuerung und Postprozessor, so dass Anwender keine Optionen oder Funktionen wählen können, die der Postprozessor nicht unterstützt.

Viele Einstellungen in der Steuerungsdefinition sind Voreinstellungen für Werkzeugweggruppen-Eigenschaften (und können dort überschrieben werden) oder Werkzeuwegparameter für bestimmte Operationen.

Mastercam kombiniert eine Maschinendefinition und eine Steuerungsdefinition, um eine Werkzeugmaschine zu repräsentieren. Als Bestandteil der Maschinendefinition wählen Sie eine Steuerungsdefinition und einen Postprozessor. Später bei der Auswahl der Maschine zum Erzeugen eines Werkzeugwegs werden die Steuerung und der Postprozessor gleichzeitig automatisch mit ausgewählt.

Wie bei der Maschinendefinition wird bei der Auswahl einer Maschine eine Kopie der Steuerungsdefinition in der Maschinengruppe abgelegt und mit dem Teil gespeichert.

  • So können Sie mit der Teiledatei an einem anderen Mastercam-Arbeitsplatz arbeiten, ohne die Maschinen- und Steuerungsdefinitionsdateien mitnehmen zu müssen.

  • So können Sie jobspezifische Änderungen vornehmen, indem Sie die lokal gespeicherte Kopie der Steuerungsdefinition (in Ihrer Teiledatei) separat vom Original auf Ihrer Festplatte bearbeiten.

Hinweis: Eine wird dabei KEINE Kopie der PST-Datei in der Teile- oder Maschinengruppen-Datei gespeichert. Die der Steuerungsdefinition zugeordnete PST-Datei muss zum Posten eines Teils auf Ihrer lokalen Arbeitsstation gespeichert sein.

Mastercam speichert Steuerungsdefinitionen im Verzeichnis CNC_MACHINES in Dateien mit der Endung *.CONTROL-<Versionsnummer>. Jede Steuerungsdatei kann mehrere Steuerungsdefinitionen für unterschiedliche Maschinentypen oder mit Konfigurationen für unterschiedliche Postprozessoren enthalten,

Siehe auch...

  • Steuerungsdefinitions-Manager

  • Erzeugen und Bearbeiten einer Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren

Kommentare oder Fragen zu diesem Thema? Schreiben Sie uns!


Erstellen und Bearbeiten einer Steuerungsdefinition

Gehen Sie in diesen allgemeinen Schritten vor, um eine neue Steuerungsdefinition zu erstellen oder eine vorhandene zu bearbeiten.

  1. Rufen Sie den Steuerungsdefinitions-Manager auf.

Die Steuerungsart, die Sie erzeugen können, wird durch die Art und Weise bestimmt, wie der Steuerungsdefinitions-Managers aufgerufen wird.

Alternativ können Sie eine vorhandene Steuerung bearbeiten. Klicken Sie im Steuerungsdefinitions-Manager auf die Schaltfläche Öffnen, wählen Sie eine Steuerungsdatei und klicken Sie auf die Schaltfläche Vorhandene Definitionen, um die Steuerungsdefinition auszuwählen.

Beachten Sie, dass Ihre Optionen zum Bearbeiten und Erzeugen begrenzt sind, wenn Sie den Steuerungsdefinitions-Manager im Dialogfeld „Eigenschaften der Maschinengruppe“ über den Werkzeugweg-Manager aufrufen. Das liegt daran, dass Mastercam Ihre Arbeit auf die lokal gespeicherte Kopie der Maschinen- und Steuerungsdefinition beschränkt, die Bestandteil der Maschinengruppe und in Ihrer Teiledatei gespeichert ist. Sie können weder Änderungen an der Steuerungsdatei (*.Control) speichern, noch eine neue Steuerungsdefinition erzeugen oder eine andere Steuerungsdatei wählen. Sie können nur Änderungen an der lokalen, in der Maschinengruppe gespeicherten Kopie speichern. Sie können später auch bei gesperrter Steuerungsdefinition Änderungen vornehmen, Sie können sie jedoch nicht in der Steuerungsdatei speichern.

  2. Wählen Sie eine Steuerungsart.

Wählen Sie beim Erstellen einer neuen Steuerung zuerst die Art. Diese entspricht dem im Maschinendefinitions-Manager angegebenen Maschinentyp. Die einzige Ausnahme dabei sind Fräs-/Drehsteuerungen, die für Fräs- oder Drehmaschinen gewählt werden können. Mastercam zeigt nur Themenseiten an, die auf ihre Steuerungsart anwendbar sind (z.B. wird keine Seite für Drehzyklen angezeigt, wenn Sie eine Steuerung für eine Fräsmaschine erstellen).

  3. Wählen Sie einen Postprozessor für Ihre Arbeit.

Wählen Sie einen Postprozessor aus der Liste, mit dem Sie in der aktuellen Sitzung arbeiten wollen. Wurde der Postprozessor zuvor für diese Steuerung konfiguriert, liest Mastercam den Postprozessortext und Zusatzwerte aus der PST-Datei aus und übernimmt sie auf den entsprechenden Seiten der Steuerungsdefinition. Andernfalls wird der Standardpostprozessortext ausgelesen.

Falls der Postprozessor nicht in der Liste enthalten ist, müssen Sie ihn hinzufügen. Klicken Sie auf die Schaltfläche Postprozessoren und dann auf Dateien hinzu. Statussymbole neben jedem Postprozessor geben an, ob er richtig konfiguriert wurde oder zum Posten zulässig ist.

Wählen Sie den Menüeintrag Vordef. Einstellungen der Steuerungsart, um einen Satz Standardwerte ohne Postprozessorselektion zu erzeugen und zu sichern.

  4. Benennen Sie die Steuerung.

Geben Sie in die Felder Hersteller und Beschreibung einen Namen und/oder beschreibende Kommentare ein.

  5. Bearbeiten Sie einzelne Gruppen von Einstellungen.

Steuerungsdefinitions-Einstellungen sind logisch in einer Reihe verschiedener Seiten gruppiert, die im Fenster „Steuerungsthemen“ aufgelistet sind. Seiten, die noch nicht in der aktuellen Sitzung aufgerufen wurden, sind durch ein Fragezeichen markiert:

Dieses ändert sich in ein Häkchen, nachdem die Seite geöffnet wurde:

Einige Seiten sind in weitere untergeordnete Seiten untergliedert. Einige Seiten sind für jede Steuerungsart gleich, während andere maschinenspezifisch sind. Zu jeder Seite können Sie ein eigenes Hilfethema mit näheren Informationen aufrufen.

Die meisten der von Ihnen eingegeben Daten werden mit der Steuerungsdefinition in Steuerungsdatei gespeichert, jedoch mit zwei wesentlichen Ausnahmen:

  • Daten der Seite „Operationsvoreinstellungen“ werden in der Voreinstellungsdatei (DEFAULTS) gespeichert.

  • Daten von der Seite „Text“ und ihren untergeordneten Seiten werden in der PST-Datei gespeichert.

Hinweis: Beim Wechsel zu einer neuen Seite werden KEINE Änderungen gespeichert, die auf der vorherigen Seite vorgenommen wurden.

  6. Speichern Sie die Steuerungsdefinition.

Über separate Schaltflächen in der Symbolleiste des Steuerungsdefinitions-Manager können Sie die neuen Einstellungen auf verschiedene Arten speichern:

Speichern Sie die Änderungen in der aktuellen Steuerungsdatei (*.control)

Sichern Sie die Änderungen in der lokalen Kopie, die in der Maschinengruppe gespeichert ist

Speichern Sie die Änderungen in einer neuen Steuerungsdatei (*.control)

Je nachdem, von wo Sie den Steuerungsdefinitions-Manager aufgerufen haben, sind nicht immer alle Speicherungsoptionen verfügbar.

Siehe auch...

  • Steuerungsdefinitions-Manager

  • Verwalten/Organisieren von Steuerungsdefinitionen

  • Wählen eines Postprozessors

  • Steuerungsdefinition – Übersicht

  • Steuerungsdefinitionen und Postprozessoren


Wie Mastercam die Steuerungsdefinitionen verwaltet

Mastercam speichert und gliedert Steuerungsdefinitionen in Steuerungsdateien. Eine solche Steuerungsdatei können Sie sich als Ringordner mit beliebig vielen Steuerungsdefinitionen vorstellen. Diese sind nach Maschinentyp und Postprozessor aufgegliedert.

Jede Steuerungsdefinition besteht aus einem Maschinentyp, der mit eine bestimmten Postprozessor verknüpft ist. Die einzelnen Steuerungsdefinitionen innerhalb einer Steuerungsdatei besitzen jeweils eine unterschiedliche Kombination aus Maschinentyp und Postprozessor. Eine typische Steuerungsdatei könnte zum Beispiel folgendermaßen aussehen:

FANUC.CONTROL-7
Control definition #1: MILL + myfanuc.pst
Control definition #2: ROUTER + myfanuc.pst
Control definition #3: MILL/TURN + myfanuc.pst
Control definition #4: LATHE + fanuc_lathe.pst
Control definition #5: MILL/TURN + fanuc_lathe.pst
Control definition #6: LATHE + fanuc_vtl.pst
Control definition #7: MILL + fanuc5ax.pst

und so weiter.

Wenn Sie beim Erstellen einer Maschinendefinition für eine Maschine, die mit dieser Steuerung arbeitet, im Maschinendefintions-Manager FANUC.CONTROL-7 wählen, wird die oben abgebildete Liste mit Steuerungsdefinitionen eingeblendet, in der Sie dann die gewünschte für die Maschine wählen können. (Im Maschinendefinitions-Manager werden nur Steuerungsdefinitionen für den Maschinentyp angezeigt, den Sie gerade erstellen.)

Für jeder Steuerungsdatei gilt:

  • Die Satz an Steuerungsarten ist festgelegt: Fräsen, Drehen, Router, Mill-Turn oder Drahten

  • Sie bestimmen, welche Postprozessoren verfügbar sind. Klicken Sie dazu auf die Schaltfläche Postprozessoren und dann auf Dateien hinzu.

Bei der Arbeit im Steuerungsdefinitions-Manager können Sie anhand dieser beiden Felder erkennen, welche Steuerungsdefinition geladen ist:

Klicken Sie auf die Schaltfläche Vorhandene Definitionen, um eine Übersicht der in der aktuellen Steuerungsdatei gespeicherten Steuerungsdefinitionen einzublenden. Klicken Sie auf eine Definition, um sie in den Steuerungsdefinitions-Manager zu laden.

Viele Anwender finden es am einfachsten, mit einer Steuerungsdefinition pro Steuerungsdatei (*.CONTROL) zu arbeiten. Dies können Sie erreichen, indem Sie bei jeder Änderung der Steuerungsart oder Auswahl eines anderen Postprozessors auf die Schaltfläche Speichern als klicken und dies in einer anderen Steuerungsdatei speichern. Andernfalls fügt Mastercam eine neue Steuerungsdefinition in die aktuelle Steuerungsdatei ein.

Hinweis: Die Steuerungsdefinition, die in die Maschinengruppe geladen und mit der Teiledatei gespeichert wird, ist nur die individuelle Steuerungsdefinition für eine einzelne Maschinentyp-Postprozessor-Kombination, nicht der Gesamtinhalt der Steuerungsdatei.

Vordefinierte Steuerungsdefinitionen

Sie können in Mastercam auch einen Satz von Voreinstellungswerten für jeden Maschinentyp anlegen und in der Steuerungsdatei speichern. Dies entspricht einer Steuerungsdefinition ohne ausgewählten Postprozessor. Im Steuerungsdefinitions-Manager wird dies folgendermaßen angezeigt:

Jeder Satz von Voreinstellungswerten wird in der Steuerungsdatei als separate Steuerungsdefinition gespeichert. Im Falle der zuvor gezeigten FANUC.CONTROL-7 zum Beispiel so:

Control definition #8: MILL Default settings
Control definition #9: ROUTER Default settings
Control definition #10: LATHE Default settings
Control definition #11: MILL/TURN Default settings

Diese können Sie nicht in der Maschinendefinition wählen oder zum Posten verwenden, aber als allgemeine „Vorlage“ zum Erstellen spezifischer Steuerungsdefinitionen. Bevor Sie eine spezifische Steuerungsdefinition erstellen, könnten Sie zum Beispiel so vorgehen:

  • Laden Sie eine vordefinierte Steuerungsdefinition.

  • Wählen Sie einen spezifischen Postprozessor.

  • Erstellen oder ändern Sie den Postprozessortext und die Zusatzwerte.

  • Bearbeiten Sie nur die Einstellungen, bei denen die Voreinstellungen geändert werden müssen.

  • Speichern Sie die neue Steuerungsdefinition. Entscheiden Sie dabei, ob Sie sie in einer neuen Steuerungsdatei oder in derselben wie die Voreinstellungen speichern.

Siehe auch...

  • Steuerungsdefinition – Übersicht

  • Erstellen und Bearbeiten einer Steuerungsdefinition

  • Steuerungsdefinitionen und Postprozessoren

  • Steuerungsdefinitions-Manager


Meldung „Daten wurden möglicherweise geändert. ...“

Gelegentlich wird beim Schließen des Steuerungsdefinitions-Managers folgende Meldung angezeigt:

Dies hängt davon ab, wie Mastercam die Steuerungsdefinitionen in der Steuerungsdatei verwaltet:

  • Sie können in jeder Steuerungsdatei mehrere Steuerungsdefinitionen speichern.

  • Jede einzelne Definition wird durch eine Kombination aus Postprozessor und Produkt identifiziert.

Diese Meldung wird angezeigt, wenn Sie den Steuerungsdefinitions-Manager schließen und entweder den Postprozessor oder das Produkt in der Liste „Steuerungsart“ geändert haben. Wenn Sie eins von beiden ändern, durchsucht Mastercam die aktuelle Steuerungsdatei und prüft, ob bereits eine Steuerungsdefinition mit der neuen Produkt-Postprozessor-Kombination vorhanden ist.

  • Falls sie vorhanden ist, wird sie von Mastercam geladen und diese Meldung wird nicht angezeigt.

  • Falls nicht, wird diese Meldung ausgegeben. Mastercam legt danach eine neue Definition an.

Wenn Sie eine der Steuerungsdefinitionsseiten öffnen und dann versuchen den Steuerungsdefinitions-Manager zu schließen oder eine andere Steuerungsdefinition öffnen, weist Mastercam in der oben gezeigten Meldung darauf hin, dass die Steuerungsdefinition möglicherweise geändert wurde und fragt ab, ob Sie die aktuelle Steuerungsdefinition in der Steuerungsdatei speichern möchten. Wenn Sie auf Ja klicken, können Sie sie in der aktuellen Steuerungsdatei speichern oder eine neue Steuerungsdatei erstellen und sie darin speichern.

Siehe auch...

  • Verwalten/Organisieren von Steuerungsdefinitionen

  • Steuerungsdefinition – Übersicht


Verwalten der Voreinstellungen für Steuerungsdefinitionen

Bei der Arbeit im Steuerungsdefinitions-Manager ist es wichtig zu beachten, dass Daten aus zwei verschiedenen Quellen angezeigt werden:

  • Postprozessortext und Integer- (ganzzahlige) und Real- (Dezimal-)Zusatzvariablen werden aus der PST-Datei ausgelesen. Diese Daten werden auf den Seiten „Zusatzwerte“ und „Text“ angezeigt. Der Steuerungsdefinitions-Manager lädt sie aus der PST-Datei, wenn Sie einen Postprozessor auswählen.

  • Werte und Einstellungen aller anderen Steuerungsdefinitionsdaten-Seiten werden aus der Steuerungsdatei *.CONTROL-<Versionsnummer> bezogen.

Daher bezieht Mastercam Voreinstellungswerte aus zwei unterschiedlichen Quellen, wenn Sie eine neue Steuerungsdefinition erstellen:

  • Vordefinierter Postprozessortext aus der PST-Datei.

  • Voreinstellungen für andere Seiten der Steuerungsdefinition aus der Steuerungsdatei *.CONTROL-<Versionsnummer>. Die einzelnen Voreinstellungstypen werden nachfolgend beschrieben.

Hinweis: Im Steuerungsdefinitions-Manager befindet sich auch die Seite „Operationsvoreinstellungen“, auf der Sie Werkzeugweg- und Operationsvoreinstellungen festlegen können. Diese Voreinstellungen sind separat in einer *.DEFAULTS-<Versionsnummer>-Datei gespeichert und fallen nicht unter dieses Thema.

Voreinstellungswerte für reguläre Seiten der Steuerungsdefinition

Die Voreinstellungen für diese Seiten der Steuerungsdefinition sind in zwei Ebenen untergliedert:

  • Auf der ersten unterhält Mastercam einige grundlegende System- bzw. „werkseitige“ Voreinstellungen. Wenn Sie eine völlig neue, leere Steuerungsdatei erstellen, verwendet Mastercam die Systemvoreinstellungen. Einige dieser Systemvoreinstellungen können Sie im Dialogfeld „Systemkonfiguration“ aufrufen und anpassen.

  • Als Zweites können Sie innerhalb jeder Steuerungsdatei eine zusätzliche Ebene von Voreinstellungen für jede Steuerungsart anlegen. Sie können sie erstellen, prüfen und bearbeiten, wenn Sie sehen

, wie die Postprozessorauswahl im Steuerungsdefinitions-Manager eingestellt ist. Diese Voreinstellungen sind nicht vorhanden, wenn Sie sie nicht erstellen und speichern, und sie gelten nur für neue Steuerungsdefinitionen, die innerhalb derselben Steuerungsdatei erstellt werden.

Öffnen Sie das Kontextmenü im Steuerungsdefinitions-Manager, um die Werte auf einer Seite auf die Voreinstellungswerte zurückzusetzen. Klicken Sie dazu mit der rechten Maustaste auf eine Datenseite und wählen Sie die Kontextmenü-Option Voreinst..

Danach setzt Mastercam die Werte automatisch auf die in der aktuellen Steuerungsdatei gespeicherten Voreinstellungen zurück, sofern diese auffindbar sind. Andernfalls werden die Daten auf die Systemvoreinstellungen zurückgesetzt.

Voreinstellungswerte für Postprozessortext

Voreinstellungswerte für Postprozessortext und Zusatzwerte werden getrennt von den übrigen Voreinstellungen der Steuerungsdefinition verwaltet. Diese sind in jeder PST-Datei unter einer [DEFAULT]-Kopfzeile/Überschrift gespeichert. Durch separate Kopfzeilen/Überschriften können Voreinstellungen für jede Steuerungsart beibehalten werden. Öffnen Sie die Seite „Text“ im Steuerungsdefinitions-Manager, um Voreinstellungen für Postprozessortext zu definieren und zu verwalten.

Mastercam unterhält zusätzlich einen Satz grundlegender System- oder „werkseitiger“ Voreinstellungen für Postprozessortext und Zusatzwerte, auf den es zugreifen kann, wenn keine postprozessor-spezifischen Voreinstellungen verfügbar sind, oder wenn Sie entscheiden diese nicht zu verwenden.

Rufen Sie im Steuerungsdefinitions-Manager das Kontextmenü der Seite „Text“ auf, um auf Voreinstellungswerte für Postprozessortext zuzugreifen oder diesen auf Voreinstellungswerte zurückzusetzen. Dies ist für eine ganze Textseite Tabellenblatt) oder eine einzelne Kategorie oder Zelle auf einer Seite möglich. Beim Zurücksetzen des Postprozessortexts auf Voreinstellungswerte

können Sie entscheiden, sie entweder auf die „Werkseinstellungen“ (System) zurückzusetzen, oder die [DEFAULT]-Kopfzeile/Überschrift aus der PST-Datei (Postprozessor) auszulesen. (Ist keine [DEFAULT]-Kopfzeile/Überschrift vorhanden, werdend die Systemvoreinstellungen verwendet.)

Wenn Sie die Werte Als Voreinstellung sichern,

importiert Mastercam die aktuellen Werte in den [DEFAULT]-Bereich der aktuellen PST-Datei der derzeit gewählten Steuerungsart.

Sie können Postprozessortextwerte auch Wiederherstellen.

In dem Fall hängt es vom Status des Postprozessors ab, welche Werte importiert werden.

  • Falls die .PST-Datei bereits einen Postprozessortextbereich besitzt — und dieser enthält einen Eintrag für die/das gewünschte Kategorie, Blatt oder Zelle— importiert Mastercam diesen Eintrag auf die aktuelle Text-Seite.

  • Andernfalls liest das System einen Wert aus dem [DEFAULT]-Bereich der PST-Datei aus.

  • Können hier keine entsprechenden Werte gefunden werden, wird die Seite mit den Systemvoreinstellungen wiederhergestellt.

Siehe auch...

  • Imortieren von Postprozessortext

  • Verwalten/Organisieren von Steuerungsdefinitionen

  • Erstellen und Bearbeiten einer Steuerungsdefinition

  • Steuerungsdefinitionen und Postprozessoren


Automatisches Erzeugen von Maschinen- und Steuerungsdefinitionen aus Postprozessoren

Bei einer Aktualisierung („Upgrade“) von Mastercam-Vorgängerversionen können Sie mithilfe der Zusatzapplikation „UpdatePost“ automatisch eine Maschinen- und Steuerungsdefinition aus einem bereits vorhandenen Postprozessor erzeugen lassen. Die Maschinen- und Steuerungsdefinitionen werden automatisch so konfiguriert, dass der konvertierte Postprozessor verwendet wird. Markieren Sie beim Ausführen der Zusatzapplikation im Dialogfeld „Postprozessoren aktualisieren“ im Feld „Dateierzeugung“ einfach die Optionen Maschinendefinition und/oder Steuerungsdefinition.

Mastercam transferiert dann automatisch Daten vom Postprozessor in die neue Maschinen- und Steuerungsdefinition. Dabei verwendet Mastercam für alle nicht vom Postprozessor gelieferten Daten voreingestellte Systemwerte für den gewählten Maschinentyp. Normalerweise werden die meisten aus dem Postprozessor ausgelesenen Werte in die Steuerungsdefinition geschrieben, während für die Maschinendefinition meistens Standardwerte verwendet werden.

Hinweise:

  • Die Steuerungs- und die Maschinendefinition erhalten dieselbe Bezeichnung wie der Postprozessor. Wird beispielsweise ein Fräsen-Postprozessor namens HAAS_VR8.PST konvertiert, erzeugt Mastercam neben der Postprozessordatei auch die Dateien HAAS_VR8.CONTROL-<Versionsnummer> und HAAS_VR8.MMD-<Versionsnummer>. Die Maschinendefition wird automatisch mit den Dateien HAAS_VR8.CONTROL-<Versionsnummer> und HAAS_VR8.PST konfiguriert.

  • Mastercam konvertiert alle nummerierten Postprozessor-Fragen in Steuerungsdefinitions-Einstellungen. Diese nummerierten Fragen sind jedoch auch im konvertierten Postprozessor zu sehen. Sie dienen nur zu Ihrer Information; Mastercam ignoriert sie und verwendet die Steuerungsdefinitions-Einstellungen.

  • Die neue Maschinen- und Steuerungsdefinition werden automatisch im Ordner CNC_MACHINES gespeichert.

  • Verwenden Sie gegebenenfalls die Zusatzapplikation „CD_Compare“, um die neue Steuerungsdefinition zu überprüfen und genau zu sehen, welche Steuerungsdefinitions-Einstellungen aus dem Postprozessor eingelesen wurden und welche Systemvoreinstellungen sind. Klicken Sie im Menü Einstellungen auf Zusatzapplikation starten, navigieren zum Verzeichnis CD_Compare und wählen dort CD_Compare.dll.

Siehe auch...

  • Konfigurieren eines Postprozessors für die Arbeit mit einer Steuerungsdefinition

  • Aktualisieren (Update) eines alten Postprozessors für die Arbeit mit Mastercam X

  • Erstellen und Bearbeiten einer Steuerungsdefinition

  • Verwalten/Organisieren von Steuerungsdefinitionen


Steuerungsdefinitionen und Postprozessoren

In Mastercam ist der Postprozessor eng mit der Maschinen- und Steuerungsdefinition verknüpft.

  • Wählen Sie im Maschinendefinitions-Manager einen Postprozessor, oder statt des eingestellten einen anderen. Diese Auswahl wird als Bestandteil der Maschinendefinition gespeichert.

  • Die Liste der Postprozessoren, aus der Sie wählen können, ist in der Steuerungsdatei (*.CONTROL) gespeichert. Nach der Auswahl einer Steuerungsdatei im Maschinendefinitions-Manager können Sie den Postprozessor wählen.

Dabei können Sie ausschließlich mit Postprozessoren arbeiten, die in der Steuerungsdatei richtig konfiguriert worden sind. Rufen Sie dazu den Steuerungsdefinitions-Manager auf, und achten Sie darauf, dass er zur Auswahl in der Maschinendefiniton zur Verfügung steht.

Hinweis: Die einzige Möglichkeit, einen anderen Postprozessor zu wählen, ist als Bestandteil der Maschinendefinition.

Viele Einstellungen in der Steuerungsdefinition ersetzen die nummerierten Fragen in Postprozessoren für frühere Mastercam-Versionen, so dass Einstellungen, für die zuvor die PST-Datei bearbeitet werden musste, jetzt in der Steuerungsdefinition vorgenommen werden sollten. Ebenso wird benutzerdefinierter Text, der früher in der TXT-Datei gespeichert wurde, jetzt in der PST-Datei gespeichert und über die Steuerungsdefinition aufgerufen.

Wenn Sie einen Postprozessor für eine Steuerungsdefinition konfigurieren, schreibt Mastercam eine Überschriftt (Kopfzeile) mit einem eindeutigen Steuerungsdefinitionsschlüssel gefolgt von steuerungsspezifischem Text. Jede einzelne PST-Datei kann separate Sätze folgender Werte und Parameter besitzen:

  • Postprozessortext einschließlich Zusatzzyklen und -parametern

  • Zusatztext

  • Zusatz- (Integer- und Real-Variablen) und Voreinstellungswerte

So können Sie denselben Postprozessor für die Arbeit mit mehreren verschiedenen Steuerungen konfigurieren - gänzlich unabhängig von einander.

Die Steuerungsdefinition arbeitet mit binären (PSB-Dateien) und textbasierten Postprozessoren (PST-Dateien) gleich gut.

Wichtig!

  • Das Erstellen der Steuerungsdefinition IST KEIN Ersatz für das Schreiben (Importieren), Bearbeiten und richtige Testen der PST-Datei, um sicherzustellen, dass sie für eine bestimmte Maschine verwendet werden kann, und IST NICHT als universeller Post-Editor gedacht. Verwenden Sie Steuerungsdefinitionen statt dessen dazu, steuerungspezifische Inhalte und Einstellungen von der Verarbeitungslogik der PST-Dateien zu trennen, so dass beide einfacher zu verwalten und beizubehalten sind.

  • Viele der Parameter auf den einzelnen Seiten des Steuerungsdefinitions-Managers definieren spezifische Postprozessorvariablen. Wenn Postprozessorblöcke in der PST-Datei einen Wert für eine Variable festlegen, der in der Steuerungsdefinition eingestellt ist, ist der Wert aus der Steuerungsdefinition vorrangig.

Siehe auch...

  • Konfigurieren eines Postprozessors für die Arbeit mit einer Steuerungsdefinition

  • Erstellen und Bearbeiten einer Steuerungsdefinition

  • Postprozessoren – Übersicht


So wählen Sie einen anderen Postprozessor

Für die meisten Anwender gleicht das Auswählen eines Postprozessors in Mastercam X dem in früheren Mastercam-Versionen. Der Hauptunterschied besteht darin, dass Sie statt der direkten Auswahl der *.PST-Datei, die Maschinendefinition auswählen müssen, die für den Postprozessor konfiguriert wurde. Das kann vor der Erzeugung der Werkzeugwege geschehen:

Wählen Sie vor dem Erzeugen von Werkzeugwegen eine Maschine aus

oder nachdem die Werkzeugwege durch die „Eigenschaften der Maschinengruppe“ im Werkzeugweg-Manager erzeugt worden sind:

Gehen Sie in folgenden Schritten vor, um einen anderen Postprozessor für bereits erzeugte Werkzeugwege auszuwählen. Dieses Verfahren betrifft typische Anwender, deren Maschinendefinitionen so eingerichtet sind, dass nur eine einzelne Steuerungsdefinition und ein einzelner Postprozessor erlaubt sind. In diesem Fall wählen Sie den neuen Postprozessor durch Laden einer anderen Maschinendefinition.

Hinweis: Für einige Betriebe können Konfigurationen so eingerichtet sein, dass jede Maschinendefinition mehrere Postprozessoren besitzt. Gehen Sie in diesem Fall stattdessen folgendermaßen vor:

  1. Klicken Sie im Werkzeugweg-Manager unter Maschinengruppe auf das Symbol Dateien.

  2. Klicken Sie im Bereich Maschine auf die Schaltfläche Ersetzen.

    Klicken Sie auf diese Schaltfläche, um die Maschinendefinition zu ersetzen.

  3. Wählen Sie die Maschinendefinition, die den gewünschten Postprozessor enthält.

  4. Mastercam zeigt den Namen der neuen Maschinendefinition mit dem neuen Postprozessor an.

    Der neue Postprozessor wird in the „Eigenschaften der Maschinengruppe“ angezeigt.

  5. Klicken Sie auf OK, um das Dialogfeld „Eigenschaften der Maschinengruppe“ zu schließen.

Siehe auch...

  • Wählen eines anderen Postprozessors– Maschinen mit mehreren Postprozessoren

  • Aktualisieren (Update) eines alten Postprozessors für die Arbeit mit Mastercam X

  • Steuerungsdefinitionen und Postprozessoren

  • Postprozessoren – Übersicht


So wählen Sie einen anderen Postprozessor aus – Maschinen mit mehreren Postprozessoren

So wählen Sie einen anderen Postprozessor aus — Maschinen mit mehreren Postprozessoren

Wenn in Ihrem Betrieb die Maschinendefinitionen so konfiguriert wurden, dass mehrere Postprozessoren unterstützt werden, gehen Sie nach folgenden Schritten vor, um einen anderen Postprozessor für den aktuellen Job zu verwenden. Die neue Postprozessorauswahl wird als Teil der „Eigenschaften der Maschinengruppe“ gespeichert, so dass beim zukünftigen Posten von Werkzeugwegen aus dieser Maschinengruppe, der neue Postprozessor verwendet wird, dieser jedoch keine anderen Teile oder Mastercam-Dateien beeinflusst.

  1. Klicken Sie im Werkzeugweg-Manager unter Maschinengruppe auf das Symbol Dateien.

  2. Klicken Sie im Bereich Maschine auf die Schaltfläche Bearbeiten (Rufzeichensymbol).

    Mastercam öffnet den Maschinendefinitions-Manager.

  3. Wählen Sie den neuen Postprozessor aus der Liste.

    Auswählen des neuen Postprozessors

    Die Liste zeigt alle Postprozessoren, die für die aktuelle Maschinen konfiguriert worden sind. Falls der Postprozessor, den Sie verwenden wollen, hier nicht aufgelistet ist, wählen Sie entweder eine andere Maschinendefinition oder er muss der Liste hinzugefügt werden.

  4. Klicken Sie auf Ja, wenn Mastercam fragt, ob die vorhandene Steuerungsdefinition ersetzt werden soll

  5. Klicken Sie auf OK, um den Maschinendefinitions-Manager zu schließen. Mastercam zeigt darauf den Namen des neuen Postprozessors an:

    Der neue Postprozessor wird in the „Eigenschaften der Maschinengruppe“ angezeigt.

  6. Klicken Sie auf OK, um das Dialogfeld „Eigenschaften der Maschinengruppe“ zu schließen.

Hinweise:

  • Wenn Sie den voreingestellten Postprozessor für eine Maschine ändern und ihn in der Maschinendefinitionsdatei auf Ihrer Festplatte speichern möchten, klicken Sie im Menü Einstellungen auf Maschinendefintion (Manager). Öffnen Sie (falls erforderlich) die gewünschte Maschinendefinition, und wählen Sie den neuen Postprozessor aus der Postprozessor-Dropdownliste. So ist gewährleistet, dass bei Auswahl dieser Maschinendefinition für spätere Mastercam-Teile der neue Postprozessor automatisch gewählt wird.

  • Wird der gewünschte Postprozessor nicht im Maschinendefintions-Manager angezeigt, prüfen Sie ob er richtig konfiguriert wurde.

Siehe auch...

  • Hinzufügen eines Postprozessors zur Maschinendefinition

  • Aktualisieren (Update) eines alten Postprozessors für die Arbeit mit Mastercam X

  • Steuerungsdefinitionen und Postprozessoren

  • Postprozessoren – Übersicht


Hinzufügen eines Postprozessors zur Maschinendefinition

Bevor Sie mit einem Postprozessor (PST-Datei) NC-Code für Ihre Werkzeugmaschine generieren können, muss eine Steuerungsdefinition dafür erstellt werden. Dies gewährleistet, dass Sie den Postprozessor im Maschinendefinitions-Manager wählen können:

Wenn ein Postprozessor richtig konfiguriert ist, sind die folgenden Bedingungen erfüllt:

  • Mastercam hat in der Postprozessor-Datei (PST) die richtigen Überschriften für den Postprozessortext und Zusatzwerte erstellt.

  • Mastercam hat überprüft, dass die Postprozessor-Datei (PST) vorhanden ist.

Richtig konfigurierte Postprozessoren werden im Steuerungsdefinitions-Manager mit einem grünen Häkchen angezeigt.

Falls Ihr Postprozessorsymbol einen anderen Status anzeigt oder der Postprozessor in der Liste fehlt, gehen Sie in folgenden Schritten vor, um ihn zu konfigurieren.

  1. Öffnen Sie im Steuerungsdefinitions-Manager die gewünschte Steuerungsdatei (*.CONTROL). Klicken Sie hier, um mehr über das Aufrufen des Steuerungsdefinitions-Managers und das Öffnen von Steuerungsdateien zu erfahren.

  2. Wählen Sie, wenn nötig, die Maschinen-/Steuerungsart.

  3. Klicken Sie auf die Postprozessorliste und wählen Sie den gewünschten Postprozessor.

  4. Prüfen Sie das Postprozessorstatussymbol, um sicherzugehen, dass er richtig konfiguriert werden kann. Falls der Postprozessor nicht in der Liste enthalten ist, klicken Sie auf die Schaltfläche Postprozessoren und dann auf Dateien hinzu, um ihn in die Liste einzufügen.

  5. Nehmen Sie bei Bedarf Änderungen auf allen Seiten der Steuerungsdefinition vor.

  6. Klicken Sie in der Symbolleiste des Steuerungsdefinitions-Managers auf die Schaltfläche Sichern (oder auf Sichern als, um sie in einer neuen Steuerungsdatei zu speichern). Als Postprozessorsymbol sollte jetzt ein grünes Häkchen angezeigt werden:

  7. Wenn Sie die PST-Datei jetzt öffnen und fast bis ans Ende blättern, ist folgende Überschrift zu sehen:

[CTRL_MILL|BPT-DX32]

Die CTRL-Überschrift enthält die Steuerungsart (MILL) und den Namen der Steuerungsdatei, in der die Steuerungsdefinition gespeichert ist. In diesem Beispiel wurde sie in der Datei BPT-DX32.CONTROL-5 gespeichert. Immer wenn Sie einen Postprozessor für eine Steuerungsdefinition konfigurieren, fügt Mastercam einen Textabschnitt mit einer Überschrift an, die Steuerungsart und Namen der Steuerungsdefinitionsdatei angibt.

Wichtig! Die Erzeugung einer Steuerungsdefinition und das Konfigurieren des Postprozessors (wie hier beschrieben), sind KEIN Ersatz für das Schreiben (Importieren), Bearbeiten und richtige Testen der Postprozessor-Datei (PST), um zu gewährleisten, dass dessen Ausgabe kompatibel zu einer bestimmten Maschine ist. Dies muss ZUSÄTZLICH zu den hier beschriebenen Schritten durchgeführt werden und wird in dieser Dokumentation nicht behandelt. Für weitere Informationen dazu wenden Sie sich bitte an Ihren Mastercam-Vertriebspartner.

Siehe auch...

  • Erzeugen und Bearbeiten einer Steuerungsdefinition

  • Steuerungsdefinitionen und Postprozessoren

  • Arbeiten mit Postprozessortext

  • Postprozessoren – Übersicht


Postprozessorstatus

Bevor Sie mit einem bestimmten Postprozessor (PST-Datei) ein NC-Programm erzeugen können, muss er richtig konfiguriert werden. Ein richtig konfigurierter Postprozessor erfüllt drei Kriterien:

  • Es wurde eine Steuerungsdefinition erstellt, die den Postprozessor mit einer bestimmten Steuerungsart verknüpft, und in einer Steuerungsdatei gespeichert.

  • Der Datenpfad für die PST-Datei wurde in Mastercam eingegeben, und das System hat überprüft, dass sie sich auch dort befindet.

  • Es existiert in der *.PST-Datei eine Überschrift mit der Steuerungsart und dem Steuerungsdateinamen, gefolgt von dem Postprozessortext für diese Steuerung.

Wenn Sie einen Postprozessor für die Arbeit in der Steuerungsdefinition wählen, wird daneben ein Symbol für den Postprozessorstatus angezeigt:

Die folgende Tabelle enhält Erläuterungen der möglichen Statussymbole (Zustandssymbole):

Die PST-Datei ist vorhanden und der Postprozessor wurde in der Steuerungsdefinition richtig konfiguriert. Der Status (Zustand) für das Posten ist OK.

Wichtig! Dies ist der einzige für das Posten zulässige Status (Zustand)!

Die PST-Datei ist nicht auffindbar und der Postprozessor wurde in der Steuerungsdefinition nicht konfiguriert.

Die PST-Datei ist vorhanden, und der Postprozessor wurde von der Bearbeitungsliste hinzugefügt. Dieses Symbol wird angezeigt, wenn Sie am Anfang einen Postprozessor aus der Liste auswählen. Speichern Sie die Steuerungsdefinition in der Steuerungsdatei, um seinen Status auf OK zu ändern.

Der Postprozessor wurde in einer Steuerungsdefinition konfiguriert, die PST-Datei ist jedoch nicht auffindbar. Dies kann vorkommen, wenn Sie die Teiledatei auf eine andere Workstation verschieben, auf der die benötigte PST-Datei nicht geladen ist.

Die PST-Datei ist vorhanden, wurde jedoch nicht für eine Steuerungsdefinition konfiguriert, oder Mastercam kann nicht ermitteln, ob es der richtige Postprozessor für jeweilige Steuerung ist. Wählen Sie den Postprozessor und erstellen Sie eine Steuerungsdefinition für diesen. Sie können mit ihm arbeiten, nachdem er in einer Steuerungsdatei gespeichert wurde.

Unbekannt; Mastercam kann den Status nicht ermitteln.

Hinweis: Alle Angaben in diesem Hilfethema gelten gleichermaßen für binäre Postprozessor-Dateien (PSB-Dateien).

Wichtig! Die Symbole für den Postprozessorstatus geben NICHT an, dass ein Postprozessor für eine bestimmte Maschine oder Anwendung richtig angepasst wurde. Die Erzeugung einer Steuerungsdefinition und das Konfigurieren des Postprozessors (wie hier beschrieben), sind KEIN Ersatz für das Schreiben (Importieren), Bearbeiten und richtige Testen der PST-Datei, um zu gewährleisten, dass dessen Ausgabe kompatibel zu einer bestimmten Maschine ist. Dies muss ZUSÄTZLICH zu den hier beschriebenen Schritten durchgeführt werden und wird in dieser Dokumentation nicht behandelt. Für weitere Informationen dazu wenden Sie sich bitte an Ihren Mastercam-Vertriebspartner.

Siehe auch...

  • Konfigurieren eines Postprozessors für die Arbeit mit einer Steuerungsdefinition

  • Erzeugen und Bearbeiten einer Steuerungsdefinition

  • Steuerungsdefinitionen und Postprozessoren

  • Postprozessoren – Übersicht


Arbeiten mit Postprozessortext

In Vorgängerversionen von Mastercam X waren Postprozessoren in zwei Dateien aufgeteilt:

  • eine *.PST-Datei, die Postprozessorvariablen, Fragen und andere Verarbeitungslogik enthielt,

  • und eine TXT-Datei mit den vom Postprozessor verwendeten Textdaten. Sie wurde oft dazu verwendet, die Benutzeroberfläche von Mastercam mit maschinen- oder steuerungsspezifischen Parametern anzupassen.

In Mastercam sind jetzt viele Funktionen der TXT-Datei in die Steuerungsdefinition integriert und die Textzeichenketten in die PST-Datei eingebunden. Anstatt die *.TXT-Datei direkt zu editieren, verwenden Sie nun die Seite „Text“ im Steuerungsdefinitions-Manager, um auf die Textinformationen der *.PST-Datei zuzugreifen. Mastercam erlaubt das Bearbeiten der Textinformationen nur dann, wenn Sie die Kopie der Maschinendefinition öffnen (öffnen Sie die Steuerungsdefinition über das Menü Einstellungen, NICHT über die Maschinengruppe).

Auf einzelnen Blättern (Tabellenblättern ähnlich) innerhalb der Seite „Text“ können Sie Texteinträge in mehreren Kategorien erstellen, bearbeiten und verwalten. Die meisten dieser Kategorien entsprechen den in den TXT-Dateien vor Mastercam X verwendeten Standardüberschriften; die übrigen sind in Mastercam X neu hinzugekommene. Die einzelnen Blätter werden in der Themenliste links im Steuerungsdefinitions-Manager angezeigt.

Die Architektur der Steuerungsdefinitionen in Mastercam erlaubt, dass jede PST-Datei mehrere Postprozessortextbereiche besitzen kann. Jedesmal, wenn Sie einen Postprozessor für eine bestimmte Steuerungsdefinition konfigurieren, schreibt Mastercam einen neuen Postprozessortextbereich und fügt ihn an die PST-Datei an. Die Textbereiche werden durch Überschriften getrennt, die den Namen der Steuerung und des Maschinentyps enthalten. Beispiel: Die Überschrift

[CTRL_MILL|BPT-DX32]

verweist auf eine Steuerungsdefinition für das Fräsen, die in der Steuerungsdatei BPT-DX32.CONTROL-9 gespeichert ist. Das bedeutet, dass Sie in einer einzelnen *.PST-Datei verschiedene Sätze an Postprozessortext mit eindeutigen Werten für verschiedene Steuerungen speichern können. Dieser Hauptüberschrift folgen getrennte Überschriften für einzelne Blätter und Kategorien.

Ein zusätzlicher Bereich in der PST-Datei enthält vordefinierten Postprozessortext. Benutzen Sie das Kontextmenü der „Text“-Unterthemenseiten im Steuerungsdefinitions-Manager zum Import von Postprozessortext oder zum Wiederherstellen von Voreinstellungswerten. Klicken Sie hier, um weitere Informationen zu Voreinstellungswerten für Postprozessortext aufzurufen.

Postprozessortextformat

Die folgende Tabelle enthält eine Übersicht darüber, wie die einzelnen Eintragstypen durch Mastercam und den Steuerungsdefinitions-Manager verarbeitet werden. Wenn eine Steuerungsdefinition mit diesem Postprozessor in Mastercam geladen wird, wird der Text aus der *.PST-Datei gelesen. Der Text wird in die *.PST-Datei geschrieben, wenn Sie sie mit dem Steuerungsdefinitions-Manager speichern.

Art des Texteintrags | Das wird in die PST-Datei geschrieben | Das wird aus der PST-Datei gelesen
Textfeld ist leer | Leere Felder werden nicht in den Postprozessor geschrieben. Wenn alle Felder unter einer Überschrift leer sind, wird auch keine Kategorieüberschrift hineingeschrieben. | Verwendet den vordefinierten Systemtext.
““ (zwei Anführungszeichen) | ““ wird in den Postprozessor geschrieben. Eine Kategorieüberschrift wird erzeugt. | Zeichenkette ist leer und das entsprechende Eingabefeld ist deaktiviert.
Beliebiger Text | Der Text wird in den Postprozessor geschrieben und es wird eine Kategorieüberschrift erzeugt. | Der Text wird eingelesen und ersetzt den vorhandenen Text.

Text für Integer und Real-Variablen ist ein wenig komplexer, da in diesem Text auch Voreinstellungswerte eingebettet sein können. Klicken Sie hier, um weitere Informationen dazu aufzurufen.

Hinweis für Benutzer vorheriger Mastercam-Versionen: Postprozessoreinstellungen können noch in der PST-Datei gespeichert werden, auch für Elemente, die in Mastercam X echte Bestandteile der Steuerungsdefinition sind. Wird derselbe Wert sowohl in der Steuerungsdefinition als auch im Postprozessor eingestellt, verwendet Mastercam die Steuerungsdefinitionseinstellung als Ausgangswert.

Siehe auch...

  • Konfigurieren eines Postprozessors für die Arbeit mit einer Steuerungsdefinition

  • Imortieren von Postprozessortext

  • Steuerungsdefinitionen und Postprozessoren

  • Verwalten von Voreinstellungsdaten für Steuerungsdefinitionen

  • Arbeiten mit der Seite „Text“


Importieren von Postprozessortext

In Mastercam X können Sie Postprozessortext entweder aus einem anderen Postprozessor der Version X oder aus Postprozessoren aus früheren Mastercam-Versionen importieren (TXT-Dateien). Dabei können die folgenden Elemente importiert werden:

  • den kompletten Postprozessortext für alle Tabellenblätter

  • ein einzelnes Blatt oder eine Seite mit Werten

  • eine einzelne Kategorie des aktuellen Tabellenblatts

  • eine einzelne Zelle

Gehen Sie zum Importieren von Postprozessor-Text folgendermaßen vor:

  1. Laden Sie die Steuerungsdefinition, in die Sie den Text importieren möchten, und öffnen Sie die Seite „Text“.

  2. Wenn Sie ein bestimmtes Tabellenblatt, eine Kategorie oder eine Zelle importieren, öffnen Sie die entsprechende Seite und klicken Sie mit der rechten Maustaste darauf.

  3. Wählen Sie die Kontextmenü-Option Import.

  4. Wählen Sie die Postprozessortextwerte für den Import.

  5. Geben Sie die Quelle des importierten Texts an:

    • Klicken Sie auf vom Post, um Text aus einem Mastercam-Postprozessor zu importieren.

    • Klicken Sie auf aus der Textdatei, um Text aus einer in früheren Mastercam-Versionen verwendeten TXT-Datei zu importieren.

  6. Wenn Sie vom Post wählen, werden Sie aufgefordert, den gewünschten Postprozessor zu wählen. Danach müssen Sie die gewünschte Kopfzeile/Überschrift des Postprozessortexts aus der PST-Datei wählen.

Wenn Sie aus der Textdatei wählen, wird das Dialogfeld „Text vom alten Post aktualisieren“ angezeigt. Darin wählen Sie ein TXT-Datei und machen zusätzliche, für die Konvertierung benötigte Angaben.

Wichtig: Die Kopfzeilen/Überschriftenstruktur in der Datei, aus der Sie importieren, muss der Struktur des Postprozessortexts entsprechen, in den Sie importieren. Kann Mastercam keine Werte für ein Tabellenblatt, eine Kategorie oder eine Zelle finden, werden die aktuellen Werte gelöscht. Wenn Sie beispielsweise Text in eine Kategorie mit dem Namen „Canned Text“ importieren, und die Kategoriebezeichnung ist im Postprozessor, aus dem Sie importieren, nicht als Kopfzeile/Überschrift vorhanden, werden die Werte aus Ihrer aktuellen Kategorie „Canned Text“ gelöscht.

Geschieht dies unbeabsichtigt, klicken Sie mit der rechten Maustaste in eine Textseite und dann auf die Kontextmenü-Option Wiederherst.. Der Postprozessortext wird erst dann in die Datei geschrieben, wenn Sie die Steuerungsdefinition speichern.

Siehe auch...

  • Arbeiten mit Postprozessortext

  • Arbeiten mit der Seite „Text“


Postprozessortext für Zusatzwerte

Beim Speichern von Postprozessortext für Integer- und Real-Variablen können Sie an die Textzeichenfolge einen Standardwert anfügen. Bei einer Integer-Variablen enthält der einzelne Eintrag im Postprozessortextbereich der PST-Datei die Bezeichnung für den Parameter und einen ganzzahligen Standardwert. Bei Realvariablen kann der einzelne Eintrag die Parameterbezeichnung sowie einen metrischen und einen inch-Standardwert enthalten.

Die Voreinstellungswerte sind folgendermaßen codiert:

[misc integers]

1. „Parametername 1“ //1

2. „Parametername 2“ //2

Für Realvariablen gilt dieses Format:

[misc reals]

1. „Parametername 1“ //1.//25,4

2. „Parametername 2“ //1.//25,4

Rufen Sie die Seite „Text“ auf, um die Namen der einzelnen Parameter einzugeben, und die Seite „Zusatzwerte“ zur Eingabe der Voreinstellungswerte. Wenn Sie versuchen die gesamte Zeichenfolge mit Voreinstellungswerten auf der Seite „Text“ einzugeben, setzt das System den gesamten Eintrag in Anführungszeichen und verarbeitet die Voreinstellungswerte nicht. Der Eintrag wird dann folgendermaßen angezeigt:

1. „Parametername 1 //1.//25.4“

Wie Mastercam die Einträge verarbeitet

Die folgende Tabelle enthält Erläuterungen dazu, wie Mastercam verschiedene Typen von Einträgen verarbeitet, wenn Sie Text in der PST-Datei speichern.

Art des Texteintrags | Was Mastercam in die PST-Datei importiert
Textfeld ist leer; keine Standardwerte. | Leere Felder werden nicht in den Postprozessor geschrieben. Wenn alle Felder unter einer Überschrift leer sind, wird auch keine Kategorieüberschrift hineingeschrieben.
Textfeld ist leer; Voreinstellungswerte ungleich null. | Systemstandardtext wird zusammen mit den Voreinstellungswerten in den Postprozessor geschrieben. Mastercam legt eine Kategorieüberschrift an. Kann auf der Seite „Zusatzwerte“ bearbeitet werden.
““ zwei Anführungszeichen; keine Voreinstellungswerte | ““ wird mit dem Standardwert 0 in den Postprozessor geschrieben. Mastercam legt eine Kategorieüberschrift an. Das Eingabefeld auf der Seite „Zusatzwerte“ bleibt aktiviert. So kann derjenige, die die Steuerungsdefinition oder den Postprozessor erstellt hat, diese Werte verwenden, ohne dass Anwender sie beim Erzeugen oder Bearbeiten von Werkzeugwegen ändern können.
““ zwei Anführungszeichen; Standardwerte ungleich null | ““ wird zusammen mit den Voreinstellungswerten in den Postprozessor geschrieben. Eine Kategorieüberschrift wird erzeugt. Das Eingabefeld auf der Seite „Zusatzwerte“ bleibt aktiviert (siehe vorherige Anmerkung).
Beliebiger Text | Der Text wird zusammen mit allen vorhandenen Voreinstellungswerten in den Postprozessor geschrieben und es wird eine Kategorieüberschrift erzeugt. Kann auf der Seite „Zusatzwerte“ bearbeitet werden.

Siehe auch...

  • Steuerungsdefinitionen und Postprozessoren

  • Arbeiten mit Postprozessortext

  • Arbeiten mit der Seite „Zusatzwerte“

  • Dialogfeld „Zusatzwerte-Integer/Real“


Tabelle ASCII-Dezimal-Hexadezimal

Siehe auch...

  • Seite „Kommunikation“

  • Seite „NC_Ausgabe“

  • Seite „Text“ (Postprozessor)


Steuerungsdefinitions-Manager

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Benutzen Sie dieses Dialogfeld als Startseite für die Erstellung und Bearbeitung von Steuerungsdefinitionen. Die Steuerungsdefinition hat zwei Hauptfunktionen:

  • Sie liefert dem Postprozessor die Daten, die er zur korrekten Verarbeitung der Werkzeugwegdaten für die gewählte Maschinendefinition benötigt. Hierdurch kann der Postprozessor eine NC-Datei erzeugen, die den Anforderungen der Steuerung entspricht.

  • Sie liefert Mastercam Daten zu Funktionsumfang und Anforderungen von Steuerung und Postprozessor, so dass Anwender keine Optionen oder Funktionen wählen können, die der Postprozessor nicht unterstützt.

Steuerungsdefinitionen werden in *.CONTROL-Dateien (Steuerungsdateien) gespeichert und verwaltet. Jede dieser Dateien kann mehrere Steuerungsdefinitionen enthalten.

Identifizieren der Steuerungsdefinition

Identifizieren Sie anhand der Felder oben im Dialogfeld die Steuerungsdefinition. Jede Steuerungsdefinition wird durch ihre Steuerungsart und ihren Postprozessor eindeutig identifiziert.

  • Wählen Sie in der Dropdownliste Steuerungsart den Maschinentyp, für den diese Steuerung vorgesehen ist. Nur Maschinendefinitionen desselben Typs können die Steuerungsdefinition verwenden. Sie können auch auf die Schaltfläche Vorhandene Definitionen klicken und eine Steuerungsdefinition aus der Liste wählen, um eine vorhandene Steuerungsdefinition aus der aktuellen *.CONTROL-Datei zu laden.

Tipp: Im Normalfall sollten Sie bei der Erzeugung einer neuen Steuerung, vor allen anderen Aktionen, die Steuerungsart wählen. Wenn Sie die Steuerungsart nach der Eingabe irgendwelcher Daten wählen, geht Mastercam davon aus, dass Sie die Art einer vorhandenen Steuerung ändern möchten statt eine neue zu erzeugen. Wenn Sie die Steuerungsart ändern, wählen Sie Ja, wenn Sie gefragt werden, ob Sie die aktuelle Arbeit speichern und die Bearbeitungssitzung fortsetzen möchten.

  • Klicken Sie auf die Schaltfläche Postprozessoren, um eine Liste der Postprozessoren anzulegen, die mit der Steuerung verwendet werden können.

  • Geben Sie in die Felder für Hersteller und Beschreibung passende Bezeichnungen ein.

  • Wählen Sie einen Postprozessor aus der Liste. Dies ist der Postprozessor, mit dem Sie in der aktuellen Steuerungsdefinitionsmanager-Sitzung arbeiten. Durch ein Status-Icon wird in der Liste neben den Postprozessoren eine korrekte/unkorrekte Konfiguration angezeigt. Wenn Sie einen Postprozessor aus einer früheren Mastercam-Version wählen, wird dieser automatisch aktualisiert.

Verwalten/Organisieren der Steuerungsdefinitionsdaten

Die in der Steuerungsdefinition gespeicherten Daten sind nach Themen gegliedert, die in der Themenverzeichnisliste links im Dialogfeld angezeigt werden.

  • Klicken Sie auf ein Thema, um die zugehörigen Daten einzublenden oder zu bearbeiten.

  • Nachdem ein Thema geöffnet wurde, erscheint ein grünes Häkchen daneben.

  • Wenn ein Thema aktiviert ist, können Sie für nähere Informationen dazu auf die Schaltfläche Hilfe klicken.

Die Themenliste (und der Inhalt jedes Themas) ändert sich je nach ausgewählter Steuerungart.

Öffnen und Speichern von Steuerungsdefinitionsdateien

Die Symbolleiste am oberen Rand des Dialogfelds bietet Zugriff auf folgende Funktionen:

  • Erstellen einer neuen Steuerungsdatei (*.CONTROL)

  • Öffnen einer vorhandenen Steuerungsdefinitionsdatei

  • Speichern der aktuellen Steuerungsdefinitionsdatei

  • Speichern der aktuellen Steuerungsdefinition in einer CONTROL-Datei.

Mastercam speichert Ihre Daten beim Wechseln zu einer anderen Seite nicht automatisch. Wenn Sie auf die Speichern-Schaltfläche klicken, weist Mastercam der Datei automatisch die Dateiendung *.CONTROL zu. Ihre Bearbeitungs- und Speicheroptionen unterscheiden sich je nach Öffnungsart des Steuerungsdefinitionsmanagers; Klicken Sie hier, um weitere Informationen dazu aufzurufen.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Erstellen und Bearbeiten einer Steuerungsdefinition

  • Steuerungsdefinitionen und Postprozessoren

  • Wie Mastercam Steuerungsdefinitionen verwaltet


Seite &bdquo;Toleranzen“

Seite „Toleranzen“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Diese Werte sind für den Postprozessor verfügbar, um sicherzustellen, dass die bei der Erzeugung von Flächen, Splines und anderer Geometrie verwendeten Toleranzen die Mindestanforderungen für die Steuerung erfüllen.

Mastercam nutzt diese Werte für CAM-Funktionen, nicht für CAD. Verwenden Sie das Dialogfeld „Systemkonfiguration“ zum Einstellen der CAD-Äquivalente. Über viele dieser Felder werden spezifische Postprozessorvariablen eingestellt; auf der Registerkarte Felddefinitionen wird erläutert welche.

Diese Seite wird für alle Maschinentypen verwendet, auch wenn sich die Voreinstellungswerte für Drahtsteuerungen davon unterscheiden.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Dateien“

Seite „Dateien“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Geben Sie auf dieser Seite die Speicherorte der von dieser Steuerungsdefinition benötigten Dateien an und definieren Sie hier die Voreinstellungen zum Speichern verschiedener Dateitypen.

  • Im Fenster Dateizuweisung sind die Dateitypen aufgelistet, für die Voreinstellungen festgelegt werden können. Klicken Sie auf einen Listeneintrag, um dessen aktuelle Voreinstellungsdatei für diesen Typ anzuzeigen. Klicken Sie auf die Ordnerschaltfläche, um eine neue Datei zu wählen.

  • Richten Sie über das Fenster Datenpfade die Standardpfade für NC- und NCI-Dateien ein. Klicken Sie auf die Ordnerschaltfläche, um neue Pfade für den jeweiligen Dateityp zu wählen.

Konfigurieren Sie anhand der anderen Optionsgruppen den Postprozessorlauf. Weisen Sie Mastercam an, wie Fehler und andere Meldungen protokolliert werden sollen, wie Vorgabeeinstellungen im Dialogfeld „Postprozessor“ eingerichtet und wie NC-Parameter verwaltet werden sollen.

Hinweise:

  • Wenn Sie eine neue Steuerungsdatei erzeugen, werden die Standardnamen und -Pfade der Operationsvoreinstellungsdateien von der Seite Dateien des Dialogfelds „Systemkonfiguration“ bezogen.

  • Benutzen Sie die Seite „Operationsvoreinstellungen“, um neue Operationsvoreinstellungsdateien zu erzeugen und zu bearbeiten.

  • Ändern Sie mithilfe der Registerkarte Dateien des Dialogfelds Eigenschaften der Maschinengruppe die Operationsvoreinstellungsdatei, die WZ-Bibliothek oder die Operationsbibliothek für eine bestimmte Maschinengruppe.

Diese Seite wird von allen Maschinentypen verwendet.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Kommunikation“

Seite „Kommunikation“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Wählen Sie auf dieser Seite die Kommunikationssoftware, die mit der Steuerungsdefinition verwendet werden soll.

Klicken Sie auf die Schaltfläche Externe Kommunikation setzen, um das Kommunikationsprogramm zu starten und die Einstellungen anzupassen.

Diese Seite wird von allen Maschinentypen verwendet.

Klicken Sie hier, um eine ASCII-Tabelle mit den dazugehörigen Kommunikationscodes einzublenden.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • DNC und serielle Kommunikation

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;NC_Dialog“

Seite „NC_Dialog“ (Steuerungsdefinitions-Manager)

Aktivieren Sie mit Hilfe dieser Seite die folgenden Optionen auf der Registerkarte „Werkzeuge“. Die folgenden Optionen werden von allen Maschinentypen, außer Drahten, verwendet.

Referenzpunkt – Ermöglicht eine Änderung der Position, von der die Operation ihren Referenzpunkt bezieht, oder die Eingabe einer operationsspezifischen Position.

WZ-Darstellung – Bietet Zugriff auf das Dialogfeld „Werkzeugdarstellung“ zur Steuerung, wie Mastercam den Werkzeugweg nach seiner Erzeugung auf dem Bildschirm darstellt.

Hinweis: Diese Seite wird in Mastercam-Drahten nicht angewendet.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;NC-Ausgabe“

Seite „NC_Ausgabe“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Definieren Sie anhand der Optionen dieser Seite, wie der NC-Code formatiert und angezeigt wird. Diese Seite wird von allen Maschinentypen verwendet.

Absolute/inkrementale Ausgabe

Stellen Sie anhand dieser Option ein, wie der Postprozessor Koordinaten ausgeben soll, inkremental oder absolut. Meist führt dies zur Ausgabe eines G90- oder G91-Codes zu Beginn Ihres Programms, der genaue Effekt hängt jedoch vom verwendeten Postprozessor ab.

Kommentare in die NC-Datei ausgeben

Üblicherweise werden alle Kommentare in die NCI-Datei geschrieben; geben Sie anhand dieser Optionen an, welche Kommentare automatisch in die NC-Datei geschrieben werden sollen. Die hier vorgenommenen Einstellungen sind Voreinstellungen, die Sie später überschreiben können. Sie können auf der Registerkarte „Dateien“ des Dialogfelds „Eigenschaften der Maschinengruppe“ NC-Kommentare konfigurieren.

N-Nummerierung

Unter diesen Optionen sind Daten zusammengefasst, die in früheren Mastercam-Versionen an mehreren verschiedenen Positionen eingestellt wurden. Alle Informationen in diesem Bereich, werden direkt in die Steuerungsdefinition geschrieben. Die „Start N-Nummer“ und das „N-Inkrement“ können auf der Registerkarte „WZ-Einstellungen“ im Dialogfeld „Eigenschaften der Maschinengruppe“ geändert werden.

Mastercam unterstützt bei der N-Nummerierung sowohl Integer- als auch Realwerte; markieren Sie das Kontrollkästchen Dezimale N-Nummern verwenden, um diese Funktion zu aktivieren. Sind die Dezimalstellen aktiviert, können in die Eingabefelder für N-Nummern Realwerte eingegeben werden. Diese sind begrenzt durch die Anzahl der Stellen der Werte, die Sie hier eingeben.

Abstände und Blockendezeichen

Diese Werte werden direkt vom Postprozessor gelesen und können nicht gleichzeitig überschrieben werden. Klicken Sie hier für eine Tabelle mit ASCII-Codezeichen.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Zusatzwerte“

Seite „Zusatzwerte“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Definieren Sie auf dieser Seite, wie die selbstdefinierten Variablensätze, die Sie für die Steuerungsdefinition anlegen können, intialisiert werden sollen.

  • Jeder im aktiven Postprozessor definierte Zusatzwertvariable wird hier als Eingabefeld angezeigt.

  • Alle im Postprozessor gespeicherten Voreinstellungswerte werden in diesen Feldern angezeigt.

  • Sie können in alle aktiven Felder einen neuen oder unterschiedliche Vorgabewerte eingeben. Beim Speichern der aktuellen Steuerungsdefinition werden die neuen Werte in den Textbereich des aktiven Postprozessors importiert.

Die hier eigegebenen Werte werden normalerweise als Voreinstellungen für alle mit dieser Steuerungsdefinition erzeugten Operationen genutzt. Diese Systemeinstellung kann wahlweise mit den Optionen unter Starte WZ-Weg Operation überschrieben werden.

  • Markieren Sie die Optionsschaltfläche Von der Voreinstellungs-OP, um unterschiedliche Vorgabewerte für jeden Operationstyp anzulegen. Rufen Sie dann die Seite „Operationsvoreinstellungen“ auf, um die gewünschten Werte für jeden Operationstyp einzugeben und in einer Vorgabedatei (*.DEFAULTS) zu speichern.

Für Mill-Turn-Steuerungen erlaubt Mastercam das Speichern zweier Sätze von Real-/Integervariablen (Zusatzwerte), einen für Fräs- und einen für Drehoperationen. Markieren Sie zum Anlegen der zweiten Seite das Kontrollkästchen Separate Fräsen und Drehen Texte und Werte verwenden. In der Steuerungsthemen-Liste erscheinen dann einzelne Themen, die für jeden Satz von Werten erzeugt wurden, die Sie dann unabhängig voneinander bearbeiten können.

Integer- und Real-Zusatzvariablen – Übersicht

In Mastercam können Sie einen Satz Integer- und einen Satz Realvariablen anlegen. Jeder Satz kann bis zu zehn verschiedene Variablen enthalten. Die Variablen, die Sie definieren, stehen zur Verfügung, wenn Sie auf der Registerkarte „Werkzeuge“ die Schaltfläche Zusatzwerte drücken oder wenn Sie die Seite Zusatzwerte wählen.

Rufen Sie die Seite „Text“ auf, um die Variablen zu benennen. Die Namen werden dann auf dieser Seite als Feldbezeichnungen angezeigt. Mastercam speichert sowohl die Variablennamen als auch die Voreinstellungswerte in der Postprozessor-Datei. Immer wenn Sie beim Arbeiten mit der Steuerungsdefinition einen anderen Postprozessor wählen, wird diese Seite mit Feldern des neuen Postprozessors aktualisiert. So können Sie beim Erstellen einer neuen Steuerungsdefinition schnell einen Satz Zusatzwerte von einem vorhandenen Postprozessor anpassen.

Anpassen der Schaltfläche „Zusatzwerte“

Mastercam bietet mehrere Methoden zum Anpassen der Schaltfläche „Zusatzwerte“, die auf der Registerkarte „Werkzeuge“ erscheint.

  • Dabei können Sie die Beschriftung der Schaltfläche und den Titel des entsprechenden Dialogfelds ändern. Rufen Sie dazu auf der Seite „Text“ die untergeordneten Seiten mit den Pfad-Parametern für die einzelnen Produkte auf.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Arbeiten mit Postprozessortext

  • Postprozessortext für Integer-/Realvariablen


Seite &bdquo;Arbeitssystem“

Seite „Arbeitssystem“ (Steuerungsdefinitions-Manager)

Wählen Sie in der Liste Arbeitskoordinatenselektion den Typ des von der Steuerung verwendeten Koordinatensystems:

Einstellung | Typische Postprozessor-Interpretation
WZ-Wechselposition | G90/91
Lokaler Arbeitsversatz | G92
Arbeitsversätze | G54, E1
Anders | Benutzerdefiniert

In älteren Mastercam-Versionen wurden diese im Dialogfeld „Zusatzwerte“ (durch Eingabe von 0, 1 oder 2) eingestellt. Sie können bei Bedarf jedoch immer noch so vorgehen oder durch diese Steuerungsdefinitions-Einstellung ersetzen.

Wählen Sie in der Liste WEbene... die Werkzeugebenen, die Mastercam bei der automatischen Erzeugung von Arbeitsversatznummern einbeziehen soll. Dabei können Sie wählen, ob Arbeitsversätze allen Werkzeugebenen zugewiesen werden oder nur denen, die transformiert werden.

Markieren Sie das Kontrollkästchen NCI-Koordinaten auf die Maschinenansicht mit Aggregat übertragen, um die Werkzeugwegkoordinaten abzubilden, wenn ein Aggregatkopf verwendet wird.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;WZ“

Seite „WZ“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Definieren Sie auf dieser Seite Voreinstellungen für WZ-Versätze, WZ-Nummern und WZ-Wechselpositionen.

Werkzeugversätze

Wählen Sie, wie WZ-Versatzdaten auf den Postprozessor übertragen werden sollen. Dabei können Sie eine von zwei Methoden verwenden:

  • WZ-Versätze direkt aus der WZ-Definition lesen (vom Werkzeug).

  • Versatznummern aufgrund der WZ-Nummer plus der hier eingegebenen Nummern erzeugen (Zum WZ hinzu).

WZ-Nummern

Wählen Sie die Optionen, die beschreiben, wie Ihr Postprozessor WZ-Nummern und Aufnahme-/Stationsnummern verarbeitet.

WZ-Wechselposition

Die WZ-Wechselposition ist die Position, zu der das Werkzeug zum Werkzeugwechsel fährt. Die WZ-Wechselposition kann an mehreren verschiedenen Stellen eingestellt werden:

  • in der Maschinendefinition,

  • in der WZ-Definition (Drehen),

  • als Parameter einer einzelnen Operation.

Benutzen Sie diesen Abschnitt, um den Standard-Ursprung der WZ-Wechselposition einzustellen. Diese Einstellung können Sie später immer noch auf einer operationsspezifischen Basis überschreiben.

Diese Seite wird bei Fräs-, Dreh-, Router- (Holzbearbeitungs-) und Fräs-/Dreh-Maschinentypen angewendet (einige der Feldbezeichnungen weichen leicht von denen für Drehmaschinen ab). Bei Fräs-/Dreh-Maschinen können Sie separate Seiten für Ihre Fräs- und Drehwerkzeuge aufrufen.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Linear“

Seite „Linear“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Geben Sie auf dieser Seite an, wie Ihre Steuerung Linearbewegungen interpoliert (sowohl G0- als auch Normalvorschub-Bewegungen).

Diese Seite wird, mit folgenden Ausnahmen, bei allen Maschinentypen angewendet:

  • Drehmaschinen besitzen keine Optionen für die Ebenenkontrolle.

  • Bei Fräs-Drehmaschinen können Sie separate Seiten für Ihre Fräs- und Drehoperationen aufrufen.

  • Drahterodiermaschinen unterstützen nur die Optionen Eckenverrundung/Genauhalt auf dieser Seite.

Definieren Sie zuerst, wie Ihre Steuerung G0-Bewegungen umsetzt. Wenn alle Achsen immer mit maximalem Vorschub verfahren, erzeugt Ihre Maschine nicht interpolierte statt gerade Bewegungen direkt auf den Punkt. Wenn G0-Bewegungen vollständig interpoliert sein sollen, dies aber nicht von Ihrer Steuerung unterstützt wird, markieren Sie die Option „Linearinterpolation mit maximalem Vorschub“. Dadurch wird der Postprozessor angewiesen, G0-Bewegungen durch voll interpolierte Linearbewegungen mit maximalem Vorschub zu ersetzen.

Wählen Sie dann für Fräsmaschinen und Router (Holzbearbeitungsmaschinen) spezifische Bewegungsoptionen. Wählen Sie für jede Ebene eine der folgenden Optionen:

  • Linearbewegungen nicht auftrennen; erlaubt 3D-Interpolation für Eilgang- und Vorschubbewegungen.

  • G0-Bewegungen (in zwei Komponenten) aufteilen (Beispiel: eine XY-Bewegungskomponente, gefolgt durch die Z-Komponente), erlaubt jedoch eine 3D-Interpolation für Vorschubbewegungen.

  • Alle Bewegungen, G0 und Vorschub, auftrennen.

Markieren Sie das Kontrollkästchen Doppelte Dialogeinträge automatisch auf gleiche Einstellung setzen, um alle Ebenen gleichzeitig zu änden.

Beachten Sie, dass Vorschubbewegungen (G1) im Postprozessor aufgetrennt sind, nicht in Mastercam. Wenn Sie Alle Bewegungen auftrennen wählen, sehen 3-Achsen-G1-Bewegungen in der Anzeige oder der Simulation immer noch so aus, als ob sie 3D-interpoliert sind, anstatt in Komponenten aufgetrennt zu sein. Sie werden jedoch später entsprechend der hier gewählten Optionen korrekt gepostet.

Ebenendefinitionen beziehen sich auf die Werkzeugrichtung / Werkzeugebene und nicht auf die Linearachsenrichtung.

Geben Sie nach dem Einstellen der linearen Bewegung für jede Ebene an, wie Ihre Steuerung Eckenverrundungen handhabt, indem Sie im untersten Bereich eine der Optionen wählen. Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen aufzurufen.

Hinweise:

  • Während diese Optionen von vielen Drahterodiermaschinen nicht verwendet werden, stehen sie doch anderen Maschinentypen, die mit Mastercam Drahten programmiert werden können, zur Verfügung, wie z.B.: Wasserstrahlschneidemaschinen, Laser- und Plasmaschneidemaschinen.

  • Viele Postprozessoren unterstützen die Exakt-Stoppmethode zum Eckenverrunden nicht. In diesem Modus stoppt die Maschine tatsächlich vor der nächsten Schnittbewegung, so dass an jeder Ecke zu eine Serie von Verzögerungs- und Beschleunigungsbewegungen kommt.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Bogen“

Seite „Bogen“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Auf dieser Seite können Sie definieren, wie die Steuerung Bögen und Helices unterstützt:

  • Wählen Sie zunächst die Ebenen, in denen die Steuerung Bögen erzeugen kann. Geben Sie für Fräsmaschinen an, ob und in welchen Ebenen Helices unterstützt werden.

  • Stellen Sie für jede Ebene mit Bögenunterstützung ein, wie die Steuerung die Zentrumspunkte definiert. Wählen Sie eine Methode aus der Dropdownliste.

  • Geben Sie dann an, ob die Steuerung 360-Grad-Bögen zulässt. Falls nicht, stellen Sie ein, ob Bögen in Quadranten- oder 180-Grad-Segmente aufgetrennt werden sollen.

  • Wählen Sie abschließend die von Ihrem Postprozessor unterstützten Fehlerüberprüfungsroutinen.

Tipp: Markieren Sie das Kontrollkästchen Doppelte Dialogeinträge automatisch auf gleiche Einstellung setzen, wenn die Einstellungen für die einzelnen Ebenen gleich sind.

Steuerungen für Dreh-, Draht- und Fräs-/Holzbearbeitungsmaschinen (Router) werden auf derselben Seite konfiguriert, außer es steht nur eine Ebene zur Verfügung (und keine Optionen für die Helix-Unterstützung). Bei Fräs-/Drehmaschinen können Fräs- und Drehoperationen auf separaten Seiten individuell konfiguriert werden.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Rotation“

Seite „Rotation“ (Steuerungsdefinitions-Manager)

Verwenden Sie die Einstellungen auf dieser Seite für eine zusätzliche Anpassung der Rotationsachsenparameter aus der Maschinendefinition.

G0-Rotationsbewegungen aufteilen

Markieren Sie diese Option, um Rotationsbewegungen im Eilgang aufzutrennen, wenn sie die in der Maschinendefinition eingestellten Rotationsachsenlimits überschreiten.

Versuchen, die Maschine auf eine bi-stabile Position einzustellen

Markieren Sie diese Option, wenn Mastercam bistabile Lösungen für Rotationsachsenpositionen berechnen soll. Der Postprozessor versucht möglicherweise mit der zweiten Lösung innerhalb der Limits zu bleiben oder die Maschinenbewegung zu reduzieren. Je nach den Bedingungen und dem Postprozessor kann dies zu einem Rückzug und einer Neupositionierung des Werkzeugs führen.

In der nachfolgenden Abbildung ist eine bistabile Position dargestellt. Sie zeigt ein einzelnes Werkzeug, das so montiert ist, dass es in zwei Achsen (grüner und roter Zylinder) rotieren kann. Das blaue und das gelbe Werkzeug stellen zwei mögliche Positionen desselben Werkzeugs dar. Beachten Sie, dass das Werkzeug in der blauen oder gelben Position dieselbe Rotationsstellung einnehmen kann, indem die grüne Achse um 180 Grad gedreht und die rote Rotationsachse umgedreht wird. Durch Auswahl der bistabilen Option akzeptiert Mastercam beide als gültige Lösungen. Das Testen beider Fälle kann die Maschine in die Rotationslimits bringen, die in der Maschinendefinition eingestellt sind.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Vorschub“

Seite „Vorschub“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Definieren Sie auf dieser Seite, wie der Postprozessor die für die einzelnen Operation eingegebenen Vorschubwerte interpretieren soll. Gehen Sie dabei für Fräsen und Router folgendermaßen vor: Gehen Sie dabei für Fräsen folgendermaßen vor:

  • Wählen Sie die passende Achsengruppe für Ihre Maschine: 3-Achsen, 4-Achsen oder 5-Achsen. Dabei brauchen Sie nur in dem Bereich Angaben zu machen, der auf Ihre Maschine zutrifft. Nehmen Sie in mehreren Bereichen Einstellungen vor, wenn diese Steuerung für mehrere Maschinentypen gewählt werden kann.

  • Geben Sie dann an, in welcher Einheit der Vorschub gemessen wird. Stellen Sie die Einheiten für Linear- und Rotationsvorschübe getrennt ein.

Sie können bei Drahterodiermaschinen auswählen, ob ein Vorschubcode in die NC-Datei ausgegeben werden soll oder nicht. Mastercam gibt den Vorschub aus, der in der für eine Operation gewählten Leistungsbibliothek eingestellt ist.

Sie können für alle Maschinentypen einstellen, dass G0-Bewegungen als Linearbewegungen mit maximalem Vorschub ausgegeben werden. Außerdem können Sie wählen, dass Vorschübe für Bogenbewegungen so angepasst werden, dass eine konstante Spanlast eingehalten wird.

Hinweise:

  • Viele Steuerungen verfügen nicht über die interne Logik zur Unterstützung dieser Features/Funktionen.

  • Verwenden Sie die Maschinendefinition zum Einstellen der tatsächlichen Werte für den Maximal- und Minimalvorschub, einschließlich des Minimalvorschubs für Bogenbewegungen.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;G4x-Versatz“

Seite „G4x-Versatz“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Auf dieser Seite weisen Sie Mastercam an, wie die Steuerung den WZ-Versatz durchführen soll und welche Versatzoptionen dem Anwender zur Verfügung stehen sollen.

Mit dem ersten Kontrollkästchen geben Sie an, ob die Steuerung überhaupt einen WZ-Versatz unterstützt. Wenn diese Option nicht markiert ist, kann Steuerung nicht als Versatztyp ausgewählt werden, die Auswahl der Option „PC“ zur Berechnung versetzte Werkzeugwege durch Mastercam ist jedoch möglich. Wenn diese Option ausgewählt ist, sind auch die anderen aktiviert.

  • Wenn Ihre Steuerung die Aktivierung des WZ-Versatzes bei Bogenbewegungen erlaubt, wählen Sie diese Option hier.

  • Durch Markieren der Optionen Die Steuerung unterstützt... aktivieren Sie die Funktionen der Verschleißversatzberechnung. Diese stehen dann beim Erzeugen von Werkzeugwegen in der Liste der Versatzarten zur Verfügung:

  • Wählen Sie bei Eignung diese Option, um Mastercam darüber zu informieren, dass diese Steuerung den WZ-Versatz über dem Teil ein-/ausschaltet. Durch diese Einstellung wird der Werkzeugweg oder die NCI-Datei nicht verändert, sie steht dem Postprozessor jedoch zur Verfügung und muss dort ausgeführt werden. Normalerweise wird diese Option zusammen mit den Optionen Nach erster Bewegung eintauchen und Rückzug vor letzter Bewegung aus dem Dialogfeld „Ein-/Ausfahren“ verwendet.

Markieren Sie das Kontrollkästchen Werkzeugweg optimieren, um diese Option standardmäßig für neue Werkzeugwege zu aktivieren. Dies hat zur Folge, dass Mastercam Bögen aus dem Werkzeugweg entfernt, wenn diese in dem versetzten Werkzeugweg kleiner als der Radius des gewählten Werkzeugs sind.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • WZ-Versatz

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren

Comments or questions about this topic? Let us know!


Steuerungsdefinition – Postprozessorenliste

Legen Sie in diesem Dialogfeld die Liste der verfügbaren Postprozessoren an, die für diese Steuerungsart gewählt werden können. Klicken Sie auf die Schaltflächen Dateien hinzu und Dateien löschen, um Postprozessoren in die Liste einzufügen oder daraus zu löschen.

Die darin aufgelisteten Postprozessoren sind danach in zwei Dialogfeldern verfügbar:

  • In der Postprozessorenliste im Steuerungsdefinitions-Manager:

  • Bei der Auswahl eines Postprozessors im Maschinendefintions-Manager.

Bei jedem Postprozessor in der Liste zeigt ein Zustandssymbol an, ob er für die Steuerung richtig konfiguriert wurde. Klicken Sie hier, um weitere Informationen zu den Zustandssymbolen des Postprozessors einzublenden.

Hinweise:

  • Wenn Sie Postprozessoren aus vorherigen Mastercam-Versionen verwenden wollen, müssen Sie sie zuerst mit der Zusatzapplikation „UpdatePost“ in Mastercam X-Postprozessoren konvertieren.

  • Die Postprozessorenliste gilt nur für Steuerungen des momentan angegebenen Maschinentyps. Wenn Sie beispielsweise gerade an einer Steuerungsdefinition für eine Drehmaschine arbeiten und in diesem Dialogfeld eine Postprozessorenliste anlegen, ist die Liste nur für Drehmaschinensteuerungen verfügbar - nicht für Fräs- oder andere Maschinen.

Weitere Informationen zu...

  • Wählen eines Postprozessors

  • Konfigurieren eines Postprozessors für die Arbeit mit einer Steuerungsdefinition

  • Postprozessorstatus


Liste vorhandener Definitionen

Dieses Dialogfeld zeigt alle bisher in der aktuellen Steuerungsdefinitionsdatei gespeicherten Steuerungsdefinitionen an. Jede Steuerungsdefinition besteht aus einem Postprozessor, der mit einer Steuerungsart verknüpft wurde. Klicken Sie in der Spalte Typ auf eine Definition und dann auf OK, um sie in der aktuellen Arbeitssitzung in den Steuerungsdefinitions-Manager zu laden.

Weitere Informationen zu...

  • Verwalten/Organisieren von Steuerungsdefinitionen


Seite &bdquo;Maschinenzyklen“

Seite „Maschinenzyklen“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Sie können auf dieser Seite eine Reihe von Variablen einstellen, die bestimmen, wie die Steuerung verschiedene Maschinenzyklen durchführt. Auf weiteren Detailseiten können Sie spezifischere Optionen für Bohrzyklen und Drehen-Zusatzzyklen einstellen. Klicken Sie oben auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen aufzurufen.

Markieren Sie für Fräs-/Drehmaschinen das Kontrollkästchen Separate Bohrzyklus-Aktivierungsoptionen für das Fräsen und Drehen verwenden, um separate Seiten für Fräs- und Dreh-Bohrzyklen anzulegen, auf denen Sie ihre Optionen separat einstellen und verwalten können.

Alle Maschinentypen verwenden dieselbe Version dieser Seite. Klicken Sie auf eine Detailseite, um mehr über die Optionen bestimmter Zyklen zu erfahren.

  • Drehen/Fräsen/Router Bohrzyklen

  • Drehen Zusatzzyklen

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Bohrzyklen“

Seite „Bohrzyklen“ (Steuerungsdefinitions-Manager)

Definieren Sie auf dieser Seite, welche Bohrzyklen später Zyklusdaten ausgeben. Bohrzyklen, die hier nicht markiert werden, stehen Anwendern weiterhin zur Verfügung, führen jedoch zur Ausgabe eines „aufgelösten Codes“ (keine Zyklen sondern Einzelsätze).

Für Fräs-/Drehmaschinen können Sie wählen, ob es separate Versionen dieser Seite für Fräs- und Dreh-Bohroperationen geben soll. Es gibt eine separate Seite zum Aktivieren und Konfigurieren von Dreh-Zusatzzyklen.

Die Optionen auf dieser Seite wirken sich auf die folgenden Werkzeugwegbereiche aus:

  • Registerkarte „Bohrzyklus“ (Drehen)

  • Fräsen/Router – Bohrzyklen (Seite „Technologie“)

Hinweis: Rufen Sie die Seite „Text“ auf, um Namen/Bezeichnung der einzelnen Zyklen zu bearbeiten und für jeden Zyklus die Parameter anzugeben, die beim Erzeugen eines Werkzeugwegs angezeigt werden.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Drehen Zusatzzyklen“

Seite „Drehen Zusatzzyklen“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Geben Sie Mastercam auf dieser Seite an, in welcher Weise Ihre Steuerung Zusatzzyklen für Dreh- und Gewindedreh-Werkzeugwege unterstützt. Markieren Sie die Kontrollkästchen der einzelnen Werkzeugwegtypen, um sie zu aktivieren, wenn das von Ihrer Steuerung unterstützt wird.

  • Bei Zusatzzyklen fürs Drehen wird beim Versuch, einen nicht unterstützten Werkzeugweg zu erzeugen, eine Fehlermeldung ausgegeben.

  • Sind beim Gewindedrehen Zyklen oder Ausgabeformate nicht aktiviert, können sie dennoch gewählt werden, erzeugen aber langen Ausgabecode.

Einstech- und Gewindedreh-Werkzeugwege verfügen über zusätzliche Sekundäroptionen zur Angabe, ob Ihre Steuerung spezifische Werkzeugwegfunktionen unterstützt. Diese entsprechen direkt Optionen und Parametern, die beim Erzeugen der Werkzeugwege angezeigt werden. Optionen, die hier nicht aktiviert sind, sind später nicht sicht- oder verfügbar. Die genannten Optionen befinden sich auf den folgenden Registerkarten für Drehwerkzeugwege:

  • Registerkarte „Einstechform“

  • Registerkarte „Einstechen - Schruppen“

  • Registerkarte „Gewinde schneiden“

Klicken Sie oben auf das Register „Felddefinitionen“, um genau zu erfahren, wie sich spezifische Optionen dieser Seite auf welche Parameter der Werkzeugwegregister auswirken.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.


Seite &bdquo;Unterprogramme“

Seite „Unterprogramme“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Diese Seite wird von allen Maschinentypen verwendet. Für Drahterodiermaschinen ist auf dieser Seite nur das Kontrollkästchen zum Aktivieren von Unterprogrammen für Drahtoperationen verfügbar.

Mastercam verwendet Unterprogramme auf zwei verschiedene Arten:

  • Transformierende Unterprogramme werden durch Werkzeugweg-Transform-Operationen (X-Form) erzeugt.

  • Nicht-transformierende Unterprogramme werden durch Tiefenschnitte und Bohroperationen erzeugt. Diese Unterprogrammarten sind nur in Mastercam Fräsen und Router verfügbar.

Geben Sie auf dieser Seite Mastercam an, wie Ihre Steuerung beide Arten von Unterprogrammen unterstützt.

  • Markieren Sie zunächst das Kontrollkästchen Steuerung unterstützt Unterprogramme, um anzugeben, ob Unterprogramme überhaupt unterstützt werden. Falls die Steuerung verschachtelte Unterprogramme unterstützt, geben Sie die maximale Anzahl von Ebenen ein.

  • Die Optionen im Bereich Spiegel- und Rotieren-Routinen gelten nur für transformierende Unterprogramme. Wenn Mastercam Unterprogramme erzeugen soll, wenn Sie Spiegel- oder Rotationstransformationen erzeugen, markieren Sie hier die entsprechenden Optionen. Auch wenn die Optionen nicht aktiviert sind, können Sie dennoch Werkzeugwege transformieren, Mastercam gibt dann jedoch langen Code statt Unterprogramme aus.

  • Die anderen Optionengruppen gelten für alle Unterprogramme.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Operationsvoreinstellungen“

Seite „Operationsvoreinstellungen“ (Steuerungsdefinitions-Manager)

Klicken Sie auf die Registerkarte „Felddefinitionen“, um nähere Informationen zu den einzelnen Optionen des Dialogfelds aufzurufen.

Erstellen und bearbeiten Sie auf dieser Seite Sätze von Voreinstellungen für Werkzeugwege. Diese sind in Dateien mit der Erweiterung *.DEFAULT-<Versionsnummer> gespeichert. Jede Datei enthält Voreinstellungen für alle Mastercam-Werkzeugwege. Sie können Sie nach Bedarf überschreiben oder anpassen und beliebig viele .DEFAULT-Dateien anlegen.

  • Verwenden Sie diese Seite, um die DEFAULT-Dateien selbst anzulegen und zu modifizieren.

  • Rufen Sie die Seite „Dateien“ auf, um der Steuerungsdefinition eine Datei zuzuweisen. Diese liefert die Voreinstellungswerte für alle Operationen, die erzeugt werden, während die Steuerungdefinition geladen ist.

Falls Sie mit einer leeren Datei beginnen möchten, können Sie in der Symbolleiste auf die Schaltfläche Operationen, Gruppen und Werkzeuge löschen klicken, um alle Einträge zu entfernen. Arbeiten Sie mit dem Kontextmenü, um neue Operationen in die Liste einzufügen oder ihre Darstellung zu ändern. Öffnen Sie den Ordner einer Operation und klicken Sie zum Bearbeiten auf ihr Parameter-Symbol. Die Funktionsweise des Operationslistenfensters ist der des Werkzeugweg-Managers sehr ähnlich. Klicken Sie hier, um weitere Informationen zum Bearbeiten der DEFAULTS-Datei und zum Einfügen neuer Operationen aufzurufen.

Sind Ihre Änderungen abgeschlossen, klicken Sie auf ... speichern, um die neue Datei anzulegen oder Ihre Änderungen zu speichern.

Arbeiten mit englischen (inch) oder metrischen Voreinstellungsdateien

Arbeiten Sie zum Zugriff auf inch- und metrische Voreinstellungen mit separaten Seiten. So können Sie, unabhängig vom momentan in Mastercam geladenen Modus, einen oder beide Sätze von Voreinstellungswerten bearbeiten. Das Bearbeiten der Voreinstellungswerte hier im Steuerungsdefinitions-Manager hat nicht zur Folge, dass beim Schließen des Dialogfelds inch- oder metrische Werte aktiviert werden. (Laden Sie zum Wechseln der Einheit (inch- oder metrischer Modus) eine Konfigurationsdatei mit der passenden Einheit. Klicken Sie in der Menüleiste auf Einstellungen, Konfiguration und wählen Sie in der Liste Aktuell eine Konfigurationsdatei aus.

Hinweise:

  • Diese Seite bietet dieselben Funktionen wie das Dialogfeld „Ändern der Operationsvoreinstellungen“.

  • Die Voreinstellungsdatei selbst ist kein Bestandteil der Steuerungsdefinition und wird auch nicht mit ihr gespeichert. Die Funktionen auf dieser Seite werden im Steuerungsdefinitions-Manager aus zweckmäßigen Gründen bereitgestellt, das es oft nützlich ist, maschinen- und steuerungsspezifische Sätze von Voreinstellungswerten anzulegen. Viele Anwender nutzen jedoch dieselben Voreinstellungsdateien für mehrere unterschiedliche Maschinen oder Steuerungen.

Wichtig! Die anderen Speicherfunktionen im Steuerungsdefinitions-Manager wirken sich nicht auf diese Seite aus. Sie müssen auf die Schaltfläche Voreinstellungen sichern klicken, um alle vorgenommenen Änderungen zu speichern.

Weitere Informationen zu...

  • Arbeiten mit Operationsvoreinstellungsdateien


Seite &bdquo;Text“

Seite „Text“ (Steuerungsdefinitions-Manager)

Verwenden Sie die einzelnen Tabellenblätter der Seite „Text“, um Postprozessortexteinträge in einer Reihe verschiedener Kategorien zu erzeugen, zu bearbeiten und zu verwalten. Diese sind in der Steuerungsthemenliste links im Fenster aufgeführt. Die meisten Kategorien entsprechen den Standardüberschriften, die in den Postprozessor-*.TXT-Dateien vor Mastercam X verwendet wurden. Die anderen sind in Mastercam X neu hinzugefügte Kategorien.

Sie können die Textinformationen nur dann bearbeiten, wenn Sie die Kopie der Maschinendefinition öffnen (wählen Sie dazu im Menü Einstellungen den Eintrag Steuerungsdefinition (Manager)). Mastercam verhindert das Ändern der Textinformationen, wenn Sie die lokale Kopie der Steuerungsefinition über eine Maschinengruppe im Werkzeugweg-Manager öffnen.

Klicken Sie nach dem Öffnen der Kopie der Steuerungsdefinition in der Steuerungsthemenliste auf ein Thema, um die entsprechenden Texteinträge einzublenden. Sie werden auf einer Art Tabellenblatt angezeigt, wo Sie sie nach Bedarf bearbeiten können. Klicken Sie doppelt in ein Feld, um einen Wert einzugeben oder zu bearbeiten.

  • Klicken Sie mit der rechten Maustaste in eine Datenzelle des Tabellenblatts, um weitere Bearbeitungsfunktionen aufzurufen und Text aus anderen Quellen zu importieren.

  • Drücken Sie die Taste [Tab] oder die Taste [Umschalt+Tab], um im Dateneingabemodus von Zelle zu Zelle zu springen.

  • Für Integer-/Realvariablen können Sie zusätzlich zur Textbezeichnung voreingestellte Integer- oder Dezimalwerte in die Textzeile einbetten. Klicken Sie hier, um weitere Informationen dazu aufzurufen.

  • Der graue Text in der linken Randspalte „Beschreibung“ ist der Voreinstellungstext des Systems. Dieser kann nicht bearbeitet werden. Die verschiedenen Texteinträge, die Sie eingeben, ersetzen ihn in der Benutzeroberfläche.

Wie Mastercam Texteinträge interpretiert

Die folgende Tabelle zeigt, wie Mastercam verschiedene Arten von Texteinträgen für die meisten Arten von Postprozessortext interpretiert/verarbeitet. Klicken Sie hier, um eine Tabelle für Integer-/Realvariablen einzublenden.

Art des Texteintrags | Was Mastercam in die PST-Datei importiert
Kein Text | Leere Felder werden nicht in den Postprozessor geschrieben. Wenn alle Felder unter einer Überschrift leer sind, wird auch keine Kategorieüberschrift hineingeschrieben.
““ zwei Anführungszeichen | Mastercam schreibt die Anführungszeichen in den Postprozessor und erzeugt eine Kategorieüberschrift.
Beliebiger Text | Der Text wird in den Postprozessor geschrieben und es wird eine Kategorieüberschrift erzeugt.

Optionen des Kontextmenüs

Das Kontextmenü ist nur dann verfügbar, wenn Sie in eine Datenzelle klicken. Klicken Sie hier, um weitere Informationen zur Arbeit mit Voreinstellungswerten für Postprozessortext aufzurufen.

  • Import – Importieren Sie mit dieser Funktion ein ganzes Blatt, eine Kategorie oder eine einzelne Zelle aus einem anderen Postprozessor oder aus einer *.TXT-Datei, die mit einer Mastercam-Vorgängerversion erzeugt wurde. Klicken Sie hier, um weitere Informationen dazu aufzurufen.

  • Voreinst. – Wählen Sie mit dieser Funktion die Quelle der Voreinstellungswerte für das/die aktuelle Blatt, Kategorie oder Zelle. Sie können entweder systemweite Voreinstellungswerte wählen oder die Postprozessorvoreinstellung. Die Postprozessorvoreinstellung ist der allgemeine Text, wie er ursprünglich in der Postprozessor-Textdatei zu finden ist.

  • Wiederherst. – Ersetzen Sie mit dieser Funktion den Inhalt eines Blattes, einer Kategorie oder einer Zelle durch die Systemvoreinstellungswerte.

  • Export – Schreiben Sie mit dieser Funktion das aktuelle Blatt in eine gesonderte Text- oder XML-Datei.

  • Als Voreinstellung sichern – Schreiben Sie mit dieser Funktion die aktuellen Postprozessortextwerte in den Voreinstellungsbereich [DEFAULT] der aktuellen PST-Datei.

Weitere Informationen zu...

  • Arbeiten mit Postprozessortext

  • Importieren von Postprozessortext

  • Konfigurieren eines Postprozessors für die Arbeit mit einer Steuerungsdefinition

  • Postprozessortext für Integer-/Realvariablen

  • Voreinstellungsdaten für Postprozessortext


Dialogfeld &bdquo;Steuerungsimport“

Dialogfeld „Steuerungsimport“

Wählen Sie beim Importieren von Daten in eine Steuerungsdefinitionsseite mithilfe dieses Dialogfelds die Datenquelle aus.

Klicken Sie dabei zuerst mit der rechten Maustaste auf eine Seite und dann auf eine der Import-Optionen. Danach werden Sie aufgefordert, eine Steuerungsdatei mit den gewünschten Importdaten zu wählen. Wählen Sie dann in diesem Dialogfeld die gewünschte Steuerungsdefinition innerhalb der Steuerungsdefinitionsdatei.

  • Wählen Sie zuerst eine Steuerungsart aus der Liste oben im Dialogfeld.

  • Wählen Sie dann den Postprozessor, der die Steuerungsdefinition identifiziert.

Hinweis: Beachten Sie, dass beim Import von Daten für alle Seiten die Postprozessorauswahl selbst nicht importiert wird. Auch werden keine Postprozessortexte oder Zusatzwerte importiert. Wechseln Sie zur Seite „Text“, um diese zu importieren.

Weitere Informationen zu...

  • Verwalten/Organisieren von Steuerungsdefinitionen


Seite &bdquo;Schnitte – Drahten“

Seite „Schnitte - Drahten“ (Steuerungsdefinitions-Manager)

Definieren Sie auf dieser Seite zwei Voreinstellungen für die Registerkarte „Technologie“ einer Draht-Operation.

  • Durch die Option Durchgangsnummer bei Stegschnitten zurücksetzen wird der Stegschnitt automatisch auf die Einstellung Startdurchgang # auf der Seite „Draht/Leistung“ gesetzt.

  • Mit Hilfe der Option UV-Höhe über die XY-Höhe setzen und sperren können Sie bestimmen, ob die Höhe der XY- und UV-Ketten je nach festgelegter Höhe umgeschaltet/gewechselt werden soll. Falls Sie die oberere Kontur (in Z) vor der unteren Kontur verketten und das Kontrollkästchen UV-Höhe über die XY-Höhe setzen und sperren ist markiert, wechselt Mastercam automatisch die Ketten, so dass die XY-Höhe die untere Kontur ist. Wenn das Kontrollkästchen UV-Höhe über die XY-Höhe setzen und sperren nicht markiert ist, bleibt die erste Kette die XY-Kette. Wenn Sie jedoch nach dem Verketten Werte manuell in das Drahtweg-Dialogfeld eingeben, die die XY- über die UV-Höhe setzten, wechselt Mastercam die Werte des Teils auch dann nicht, wenn das Kontrollkästchen UV-Höhe über die XY-Höhe setzen und sperren markiert ist.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Zerstörungsdrahten – Drahten“

Seite „Zerstörungsdrahten – Drahten“ (Steuerungsdefinitions-Manager)

Auf dieser Seite definieren Sie Voreinstellungen für Zerstörungs-Drahtwege.

  • Wenn auf der Seite „Schlichten“ des Dialogfelds „Drahtweg - Zerstörungsdrahten“ das Kontrollkästchen Schlichtkonturoperation hinzufügen markiert ist, erzeugt Mastercam die Schlichtoperation nach Beendigung der Zerstörungsdrahten-Schruppoperation. Ist diese Option deaktiviert, erzeugt Mastercam alle Zerstörungsdrahten-Schruppdurchgänge in der Operation und dann den Schlichtkonturdurchgang für jede Tasche.

  • Sie können für Schruppdurchgänge in Taschen-Drahtwegen Ein-/Ausfahrbewegungen wählen, wenn diese Bewegungen für die Steuerung erforderlich sind. Dies ist meist bei Drahterodiermaschinen von Agie der Fall. Geben Sie für die Länge der Bewegungen den Prozentsatz des WZ-Durchmessers ein. Per Voreinstellung ist dieser Wert 10 % des Drahtdurchmessers. Bei einem kleinen Drahtdurchmesser könnte die so erzeugte Bewegung für einige Steuerungen jedoch zu klein sein, um sie zu verarbeiten, so dass Sie bei Bedarf einen höheren Prozentsatz eingeben können. Beachten Sie, das der Prozentsatz relative niedrig gehalten werden sollte, da Mastercam diese Bewegungen keiner Kollisionskontrolle unterzieht.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;4-Achsenweg - Drahten“

Seite „4-Achsenweg - Drahten“ (Steuerungsdefinitions-Manager)

Geben Sie auf dieser Seite an, welche 4-Achsen-Drahtwegtypen durch die Steuerung unterstützt werden sollen. Bei konischen Drahtwegen werden Drahtbewegungen als Linearbewegungen ausgegeben, während sie bei direkten Drahtwegen sowohl als Linear- als auch als Bogenbewegungen ausgegeben werden. Es stehen die folgenden Einstellungen zur Verfügung:

Steuerung unterstützt direkte Drahtwege – Markieren Sie dieses Kontrollkästchen, wenn Ihre Maschinensteuerung direkte Drahtwege unterstützt.

Steuerung unterstützt konische Drahtwege – Markieren Sie dieses Kontrollkästchen, wenn Ihre Maschinensteuerung konische Drahtwege unterstützt.

Direkte Kreise und Linienpaare im Drahtweg aktivieren – Markieren Sie dieses Kontrollkästchen, wenn direkte 4-Achsen-Drahtwege sowohl mit Bogen(Kreis)- als auch mit Linear-Bewegungen vorhanden sind, und Bogenbewegungen als Bögen gepostet werden sollen, wenn sie mit Linearbewegungen in der anderen Ebene übereinstimmen. Wenn dieses Kontrollkästchen nicht markiert ist, werden Bögen (Kreise), die mit Linearbewegungen übereinstimmen, anhand der Linearisationstoleranz aufgetrennt. Verwenden Sie diese Option, wenn Ihre Drahtmaschine kombinierte Linien/Bögen-Bewegungen verarbeiten kann.

Max. Zustellung für direkte und konische Drahtwege – Geben Sie hier die maximale Zustellung für sowohl konische als auch direkte Drahtwege ein, die durch Ihre Steuerung erlaubt ist.
Hinweis: In einer 4-Achsen-Operation wird die maximale Zustellung verwendet, wenn als Sync-Methode die Option Nein eingestellt ist. Normalerweise ist eine Form der Kettensynchronisation zwischen den XY- und UV-Ketten erforderlich, damit der Drahtweg korrekt erzeugt wird.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Kontur-Rücklaufschnitt – Drahten“

Seite „Kontur-Rücklaufschnitt – Drahten“ (Steuerungsdefinitions-Manager)

Auf dieser Seite können Sie Werte für den Postprozessor einstellen, wenn für einen Drahtweg auf der Seite „Technologie“ eines Kontur- oder 4-Achsen-Drahtweg-Dialogfelds als Bearbeitungsmethode die Option Rücklauf eingestellt ist. In älteren Mastercam-Versionen wurden diese Optionen als Parameter im Postprozessor eingestellt. Die Kontur-Codes können beim aktuellen Punkt, der aktuellen Bewegung, dem vorherigen Punkt oder modal geändert werden.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Zusatz-Rücklaufschnitt – Drahten“

Seite „Zusatz-Rücklaufschnitt – Drahten“ (Steuerungsdefinitions-Manager)

Geben Sie auf dieser Seite an, wie die Zusatzregistercodes ausgegeben werden sollen, wenn auf der Seite „Technologie eines Kontur- oder 4-Achsen-Drahtweg-Dialogfelds als Bearbeitungsmethode die Option Rücklauf ausgewählt ist. In älteren Mastercam-Versionen wurden diese Optionen als Parameter im Postprozessor eingestellt. Die Zusatzregistercodes können auf dem aktuellen Punkt, der aktuellen Bewegung, dem vorherigen Punkt oder modal geändert werden. Ein Code ist modal, wenn er so lange wirksam bleibt, bis der nächste Code gelesen wird.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Drahten-Leistungsbibliotheken

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite „Radius – Drahten“ (Steuerungsdefinitions-Manager)

Definieren Sie auf dieser Seite, welche Eckentypen durch die Drahtsteuerung unterstützt werden. Die beiden optionalen, auf dieser Seite aufgelisteten Eckentypen, sind Schleife und Anders:

Die folgenden Eckentypen sind nicht optional und sind deshalb im Steuerungsdefinitions-Manager nicht aufgelistet:

  • Konisch

  • scharfe

  • Konstant

  • Fest

Durch die hier getroffene Eckentyp-Auswahl ändert sich auch diejenige auf der Seite „Ecken“ im Drahtweg-Dialogfeld (siehe unten):

Weitere Informationen über Eckentypen für das Drahten, siehe Ecken- und Bogentypen.

Hinweis: In Mastercam Drahten ermöglicht die Option Anders die Angabe eines benutzerdefinierten Eckradius, der im Postprozessor definiert ist. Mastercam Drahten zeichnet die Ecke als gerade Linie, da der im Postprozessor definierte Eckentyp zu diesem Zeitpunkt unbekannt ist.

Auf dieser Seite befinden sich außerdem zwei Einstellungen zu Postprozessorfragen für einige Steuerungen:

  • Tangentialer Konikmodus mit Linie-Bogen-Linie erlauben (G60 Fanuc) – Aktiviert die in Fanuc-Steuerungen verwendete Konikmethode, bei der der Bogen entfernt wird, wenn eine Linie tangential an ihm anliegt und eine weitere Tangente folgt. Dabei wird das erste Linienende zum Schnittpunkt der Linien und der Radius, üblicherweise das R-Wort (eingeschlossener Radius), wird ausgegeben. Der G60-Modus bestimmt den Koniktyp mit dem eingeschlossenen Bogen.

  • Duale Eckentypen und oberer Radius mit Bögen erlauben ist meist aktiviert. Wird diese Option deaktiviert, werden sowohl die Parameter unter Bogenart und -radius als auch die Radiusoption für feste und Schleifenecken deaktiviert.

Optionen des Kontextmenüs

Voreinst. — Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import — Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Start/Anfahrt – Drahten“

Seite „Start/Anfahrt – Drahten“

Definieren Sie auf dieser Seite Voreinstellungen für Ein- und Ausfahrbewegungen in Drahtoperationen.

Wählen Sie hier den Einfädelungstyp, der von der Maschine unterstützt wird. Im Bereich „Ein/Ausfahrt“ wird abgefragt, welche Arten von Ein-/Ausfahrbewegungen von Ihrer Steuerung unterstützt werden.

Mastercam verwendet die Ein- und Ausfahrmethoden-Selektionen zum Festlegen von Voreinstellungen für Drahtoperationen, die Ein-/Ausfahrbewegungen unterstützen. Weitere Informationen zu den in Drahten unterstützten Bewegungsarten finden Sie unter dem Thema Ein- und Ausfahrten (Drahten). Zusätzlich können Sie wählen, ob Mastercam Drahtwege mit den Einstellungen dieser Seite oder der Voreinstellungs-Operation initialisieren soll. Die übrigen Optionen müssen eventuell je nach Steuerung oder Postprozessor gewählt werden.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Seite „Ein-/Ausfahrt“

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Seite &bdquo;Steuerungsmodell – Drahten“

Seite „Steuerungsmodell – Drahten“

Wählen Sie mithilfe dieser Seite ein Drahten-Maschinenmodell und eine Steuerungsversion aus.

  • Über das Feld Maschinenmodell können Sie die gewünschte Drahterodiermaschine auswählen.

  • Über das Feld Steuerungsversion können Sie die entsprechende Steuerungsversion auswählen. Dieses Feld ist nur dann verfügbar, wenn Sie ein Agie Maschinenmodell ausgewählt haben.

Optionen des Kontextmenüs

Voreinst. – Setzt entweder die aktuelle Seite oder die gesamte Steuerungsdefinition auf die Voreinstellungswerte zurück. Klicken Sie hier, um weitere Informationen dazu aufzurufen, woher die Voreinstellungswerte stammen.

Import – Importiert entweder für die aktuelle oder alle Seiten Werte aus einer anderen Steuerungsdefinition.

Beim Importieren von Werten bleiben folgende Parameter/Einstellungen jedoch unverändert:

  • Eingestellter Postprozessor, Steuerungsart und -name

  • Werkzeugweg-/Operationsvoreinstellungen

  • Postprozessortext

  • Zusatzwerte – Integer/Real

Postprozessortext und Zusatzwerte können Sie von der Seite „Text“ importieren.

Weitere Informationen zu...

  • Steuerungsdefinition – Übersicht

  • Voreinstellungen der Steuerungsdefinition

  • Wie Mastercam Steuerungsdefinitionen verwaltet

  • Steuerungsdefinitionen und Postprozessoren


Dialogfeld &bdquo;Text VOM alten POST aktualisieren“

Dialogfeld „Text VOM alten POST aktualisieren“

Importieren Sie mithilfe dieses Dialogfelds Postprozessortext aus einer Postprozessortextdatei (TXT) aus Versionen vor Mastercam X. Geben Sie den Postprozessortyp und die Versionsnummer an, bevor Sie die TXT-Datei zum Konvertieren auswählen. Der Typ des Postprozessors, dessen Text Sie importieren, muss zur Art der Steuerungsdefinition passen, in die Sie importieren.

Weitere Informationen zu...

  • Importieren von Postprozessortext

  • Arbeiten mit Postprozessortext

  • Voreinstellungsdaten für Postprozessortext


Aufrufen des Steuerungsdefinitions-Managers

Rufen Sie den Steuerungsdefinitions-Manager auf diese Weise auf ... | ... , um diese Aufgabe durchzuführen
Klicken Sie im Menü Einstellungen auf Steuerungsdefiniton (Manager)...... | Bearbeiten der aktiven Steuerung. Sie können mithilfe der Funktion „Sichern als“ eine neue Steuerung mit ihren Einstellungen erzeugen.
...und drücken Sie dann die Schaltfläche Neu. | Erzeugen einer neuen Steuerung beliebiger Art, beginnend mit einer leeren (Standard-)Steuerung.
Klicken Sie im Maschinendefintions-Manager auf die Schaltfläche Steuerungsdefinition ändern... | Bearbeiten der Steuerung, die momentan der Maschine zugewiesen ist. Mit Hilfe der Funktion „Sichern als“ können Sie eine neue Steuerung erstellen.
...und drücken Sie dann die Schaltfläche Neu. | Erzeugen einer neuen Steuerung derselben Art wie die Maschine, beginnend mit einer leeren (Standard-)Steuerung.

Wenn Sie den Maschinendefinitions-Manager vom Werkzeugweg-Manager aus aufgerufen haben, können Sie Ihre Änderungen nur in der aktiven Maschinengruppe speichern. Sie können keine neuen Steuerungsdefinitionen erstellen oder Änderungen im Orginal der Steuerungsdefinition auf der Festplatte ihres Rechners speichern.

Klicken Sie hier, um dieses Thema auszudrucken.


Steuerungsdefinitionswarnung für das Sichern der Daten

Mastercam zeigt diese Warnung an, wenn Sie die Steuerungsdefinition bearbeiten, Ihre Änderungen jedoch nicht in der aktiven Maschinengruppe gespeichert werden. Dies bedeutet, dass Ihre Änderungen in der Hauptkopie der Steuerungsdefinition in der Datei *.control gespeichert werden, diese das aktuelle Teil jedoch nicht beeinflussen.

Dies geschieht meist, wenn Sie den Steuerungsdefinitions-Manager direkt über das Menü Einstellungen aufrufen, während eine Maschinengruppe aktiv ist. Weil eine Maschinengruppe aktiv ist, sperrt der Maschinendefinitions-Manager Ihren Zugriff auf die Steuerungsdefinitions-Einstellungen, die in der Maschinengruppe gespeichert sind.

Wenn Sie die letzten Einstellungen in Ihrer aktuellen Teiledatei verwenden wollen, laden Sie einfach erneut die Maschinendefinition in die Maschinengruppe.

  1. Klicken Sie auf OK, um diese Warnmeldung zu schließen.

  2. Klicken Sie im Werkzeugweg-Manager unter Maschinengruppe auf das Symbol Dateien.

  2. Klicken Sie im Bereich Maschine auf die Schaltfläche Ersetzen.

  3. Wählen Sie die Maschinendefinition erneut und klicken Sie auf Öffnen.

Mastercam lädt daraufhin die Hauptkopie der Maschinendefinition und Steuerungsdefinition, mit Ihren letzten Änderungen, in das Teil.

Weitere Informationen zu...

  • Erstellen und Bearbeiten einer Steuerungsdefinition

Comments or questions about this topic? Let us know!


Steuerungsdefinition: Öffnungsoptionen

Immer wenn Sie den Steuerungsdefinitions-Manager aufrufen, versucht Mastercam, soweit möglich, die Steuerungsdefinition zu laden, die mit der Maschinengruppe oder Maschinendefinition verknüpft ist. Wird keine Maschinengruppe gefunden, zeigt Mastercam dieses Dialogfeld an, über das Sie entweder eine neue Steuerungsdatei (*.control) erstellen oder eine auf Ihrer Festplatte vorhandene öffnen können.

Weitere Informationen zu...

  • Erstellen und Bearbeiten einer Steuerungsdefinition

Comments or questions about this topic? Let us know!


Steuerungsdefinitionswarnung für das Sichern der Voreinstellungen

Diese Warnmeldung wird angezeigt, wenn Sie die Seite „Operationsvoreinstellungen“ im Steuerungsdefinitions-Manager geöffnet haben und auf eine andere Seite wechseln. Da Ihre Operationsvoreinstellungen in einer anderen Datei als der Rest der Steuerungsdefinition gespeichert werden (in einer DEFAULTS- statt einer CONTROL-Datei), werden Ihre Änderungen an den Operationsvoreinstellungen beim Speichern der Steuerungsdefinition nicht mitgespeichert. Mastercam blendet diese Meldung beim Wechseln zu einer anderen Seite ein, damit Sie daran denken, eventuell vorgenommene Änderungen zu speichern. Klicken Sie auf OK, um den Inhalt dieser Seite in der Voreinstellungsdatei (*.DEFAULTS) zu speichern, oder klicken Sie auf Abbrechen, um ohne Speichern fortzufahren.

Klicken Sie auf der Seite „Operationsvoreinstellungen“ auf die Schaltfläche Voreinstellungen sichern, um Ihre Werte in der Voreinstellungsdatei (*.defaults) zu speichern.

Weitere Informationen zu...

  • Seite „Operationsvoreinstellungen“

  • Arbeiten mit Operationsvoreinstellungsdateien

Comments or questions about this topic? Let us know!